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How to Use T his  Manual

Chapter 1:  Introduction and Installation This chapter gives you a brief
introduction to HiJaak PRO’s features and system requirements, and then guides
you through the installation procedure.  Finally, it explains how to use HiJaak
PRO with a mouse or a keyboard.

Chapter 2:  Getting S tarted Use this chapter to learn how to view, open, close
and print images in HiJaak PRO. This chapter also explains HiJaak PRO’s
Windows Clipboard support, and describes how to use the command line.

Chapter 3:  Changing the L ook of an Image Use this chapter to learn which
file formats you can view and how to change the view, i.e., zoom in, zoom out,
center the image, etc. It explains how to edit, perform image-processing, and
work with colors in an image. 

Chapter 4:  Converting an Image from One Format to Another Use this
chapter to learn about raster and vector formats.  This chapter lists the types of
files you can convert and the specific formats HiJaak PRO supports. The chapter
then explains how to convert a file from one format to another.

Chapter 5:  Capturing a Windows Screen Use this chapter to learn about the
three Windows screen capture methods and when to use each.  This chapter also
explains how to capture full screens, a particular window or window object, or
an area of the screen.

Chapter 6:  Capturing a DOS  Screen or Printer Output Use this chapter to
learn how to capture DOS screens.  This chapter also explains how to use HiJaak
PRO to capture data sent by your software application to your printer.

Chapter 7:  Changing Your Setup Use this chapter to change your HiJaak PRO
setup.  This chapter shows you how to configure HiJaak PRO for use with your
fax card.  This chapter also explains how to use "set files" to customize your file
conversions.  Finally, it guides you through changing defaults such as
background color, displayed palette, color reduction method, and curve quality.  

Chapter 8:  Us ing HiJaak PRO in Your Work Use this chapter to learn how to
use HiJaak PRO with both your software applications and your graphics
hardware.  This section provides information on using Object Linking and
Embedding, TWAIN, Drag-Drop, and HiJaak import filters.  

Chapter 9: Technical Support Use this chapter to assist in obtaining quick and
efficient help from your system vendor.
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 Introduction and Ins tallation

Overview

This chapter provides a brief introduction to HiJaak PRO features, the system
requirements for running the program, and instructions for installing it.  It

also describes how to use a mouse or keyboard to move around in HiJaak PRO.   

Introduction to HiJaak PRO

You can use HiJaak PRO to:

q View, edit, and image-process a file

q Convert a file from one format to another

q Capture a screen

q Print an image

q Organize your graphics files

VIEWING A F IL E  –– You can use HiJaak PRO to view images if your images are
stored in any of the source formats supported by HiJaak PRO. Viewing your
images before you convert them lets you see if the source image is as you want
it.  For a list of the formats supported by HiJaak PRO and for more information
about viewing a file, see Chapter 2: Getting Started.
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EDIT ING A F IL E  –– Once you are viewing an image, you can use the HiJaak
PRO Edit menu for:

q Cutting and pasting it to and from the Windows Clipboard

q Cropping it

q Changing a color

q Changing a font (in a vector file with text, or a DOS text
screen capture)

PROCESS ING AN IMAGE –– Depending on the format, you can select from
over 20 image processing options, including:

q Smoothing

q Distort Aspect

q Height and Width

q Horizontal and Vertical Resolution

q Rotation

q Number of Colors

q Color Reduction Method

q Palette Optimization

q Invert Colors

q Reveal Background Color Objects

q Reverse Black and White

q Halftone Screen Frequency

q Histogram Equalization

q Contrast

q Brightness

q Gamma Correction

Installation

1-2 Installation



CONVERT ING A FILE  FROM ONE  FORMAT  T O ANOT HER  –– HiJaak PRO
allows you to convert to and from more than 70 formats.  HiJaak PRO can also
choose the best file format for one of many popular software applications.

CAPT UR ING A SCREEN –– HiJaak PRO allows you to capture either Windows
or DOS screens and save them in any of HiJaak PRO’s supported raster file
formats.  Also, DOS text mode screens can be saved in vector formats.

PR INT ING AN IMAGE –– HiJaak PRO allows you to print any image you can
view, and it supports all Windows printers.

ORGANIZING GRAPHICS  F IL ES  –– HiJaak PRO provides the HiJaak Browser
utility to help you organize and update your graphics files.  See your HiJaak
Browser documentation for more information.
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Ins tallation 

Sys tem Requirements

COMPUT ER : You will need an IBM PC or compatible with a 286  (minimum),
386, or 486 microprocessor and Microsoft Windows version 3.1 or later, running
in standard or enhanced mode.  A math co-processor will speed up DXF and PCL
conversions substantially. 

Note: You need a 256 color display mode to use some color processing
functions.

DISK DR IVES : You will need a hard disk with at least 6 megabytes of free disk
space to store the HiJaak PRO program.  If you are using HiJaak PRO to convert
files from one format to another, you will need enough additional disk space to
store both your source files and the files you will create.

How to Ins tall from the Windows Program Manager

 1 Run Windows as you normally would.

 2 From the Windows Program Manager, pull down the File menu and click
on Run. You will see the Run dialog box.

 3 Put the diskette labeled Disk 1 in the a: drive or the b: drive. 

 4 Type the following:

a:\ins tall

If you put your diskette into drive b: in Step 3,
type the following:

b:\ins tall

Click on OK.

 5 You will see a screen informing  you that HiJaak
PRO is loading the install program, then you will
see the Registration screen.  Click on the Name
area and type your name.  Click on the Company
Name area and type your company name.  

 6 Click on the Registration Number area and type the registration number
found on the registration card in the front of this manual.  

Step 5: Registration Screen
Installation
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 7 Click on OK.  If you entered an invalid
registration number, you will receive a message
that you entered an incorrect number, and you
will be allowed to try again.  Once you enter a
valid registration number, you will see the Target
Drive dialog box.

 8 In the Target Drive dialog box, type the drive and
path where you wish to install HiJaak PRO.  The
default is C:\HJPRO.  Click on OK.

 9 You will see the Install Options dialog box which
has choices of Full, Custom, Network, Import
Filter, and De-Install.  Click on either Full Install,
Custom Install, or Network Install.  Full Install
installs all the HiJaak PRO files that come with
the product. Network Install, Import Filter Install,
and De-Install are described later in this chapter.
Custom Install allows you to select any or all of
the following installation options:

q DOS CAPT URE  ––  Installs all files necessary to capture
DOS screens.  When you select this option and click on
OK, you will see the DOS Capture Screen Fonts dialog
box.  Click on Code Page 850 Fonts if you are capturing
screens with European language text screens.  Otherwise,
select U.S. Fonts. 

q HP PCL  4 INT ERPRETAT ION ––  Installs all files
necessary to convert files to or from the HP LaserJet
Series II PCL 4 format.

q SAMPL E  GRAPHICS  ––  Installs all sample graphics files.

q APPL ICAT ION INT ERFACES  ––  Installs links from
HiJaak PRO to many Windows applications. 

 

Step 8: Target Drive Dialog Box

Step 9: Install Options Dialog Box
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Note: Custom Install is useful if you wish to save disk space.  

10 The installation procedure begins.  Follow the
directions on your screen.  

If you selected Full Install or Custom Install and
Application Interfaces, you will see the Add
Import Filters dialog box, with a list of supported
applications found.  Click on the application
name to which you want to add import filters.
Adding import filters will modify your
application INI file, your WIN.INI file, or both.
Click on OK to continue with installation.  

11 When installation is complete, you will see the
HiJaak PRO program group and icons.  A
message box will ask you if you want to read the
Release Notes.  These important notes include
information on menu changes and enhancements
in HiJaak PRO.  Click on Yes to read the Release
Notes.

Note: If you intend to use HiJaak PRO with a fax card, see How to
Configure HiJaak for Your Fax Card in Chapter 7: Changing Your Setup.

Step 11: HiJaak PRO Program Group

Step 10:  Add Import Filter Dialog Box

Installation
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Printer Setup

Since HiJaak PRO is a Windows application, it will print to any of the printers
you have set up in Windows.  Refer to your Windows manual for information on
printer setup.

Technical Notes

The HJPRO subdirectory contains last-minute and advanced technical
information in Windows Write (*.WRI) files.  This includes information about
Application Program Interfaces (APIs).
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Ins talling on a Network

Additional information on setting up HiJaak PRO on a network is available in
the Windows Write file NETWORK.WRI, located in the HJPRO subdirectory.

HiJaak PRO has only been tested in Novell Netware 3.11; therefore all
information in this section pertains to a Novell Netware 3.x network.
Information on other networks may vary.

Note: Your server must run Windows 3.1 or later in standard or enhanced
mode.

How to Ins tall on a Network S erver

 1 From a workstation, log on to the network and connect to the drive on
which you want to install HiJaak PRO.  You must have write rights to this
directory.

 2 Run Windows on the network server.

 3 From the Windows Program Manager, pull down the File menu and click
on Run.  You will see the Run dialog box.

 4 Put the diskette labeled Disk 1 in the a: drive or the b: drive. 

 5 Type the following:

a:\ins tall

If you put your diskette into drive b: in step 4, type the following:

b:\ins tall

Click on OK.

Installation
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 6 You will see a screen informing you that HiJaak PRO is loading the install
program, then you will see the Registration screen.  Click on the Name
area and type your name.  Click on the Company Name area and type your
company name.  

 7 Click on the Registration Number area and type the registration number
given to you with your Concurrent Use License.  This number tells HiJaak
PRO how many concurrent uses are allowed.

 8 Click on OK.  If you entered an invalid registration number, you will
receive a message that you entered an incorrect number, and you will be
allowed to try again.  Once you enter a valid registration number, you will
see the Target Drive dialog box.

 9 Type in the drive and path where you want to install HiJaak PRO.  You
should install it in a directory that will be read-only for your users.  Click
on OK.

10 You will see the Install Options dialog box.  Click on Network Install.
Click on OK.

11 You will see the Network Install Options dialog
box.  Click on Full Install on Server.  Click on
OK.  You will see the DOS Screen Capture Fonts
dialog box.  If you need to capture text mode
screens with text in European languages, click on
the Code Page 850 radio button.  Code Page 850
fonts override U.S. fonts, and once selected, are
in effect network-wide.

12 The installation begins. Follow the directions on
your screen.  

13 You will see the Add Import Filters dialog box,
with a list of supported applications found.  Click
on the application names to which you want to
add import filters.  Adding import filters will
modify your application INI file, your WIN.INI
file, or both.  Click on OK to continue with
installation.

Step 11: Network Install Options 
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14 When installation completes, you will see the HiJaak PRO program group
and icons.  You will be prompted to read the Release Notes.  These
important notes include information on menu changes and enhancements
in HiJaak PRO.  Click on Yes to read the Release Notes.

15 Follow the procedure below to install HiJaak PRO on each workstation.

How to Ins tall on a Workstation

 1 From the workstation on which you want to install HiJaak PRO, log on to
the network and run Windows.

 2 From the Windows Program Manager, pull down the File menu and click
on Run.

 3 You will see the Run dialog box.  Type your path to HiJaak PRO followed
by HJSETUP.  For example:

n:\hjpro\hjsetup

Click on OK. 

 4 You will receive a message verifying the location of your HJPRO directory.
Click on OK to continue installation.

 5 You will see the Install Options dialog box.  Click on Network Install.
Click on OK.

 6  You will see the Network Install Options dialog box.  Click on
Workstation Install.  Click on OK.

 7  You will see the Add Import Filters dialog box.  Click on the application
names to which you want to add import filters.  Adding import filters will
modify your application INI file, your WIN.INI file, or both.  Click on OK
to continue with installation.

 8 The HiJaak PRO program group and icons are added to your workstation.
Installation
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Removing HiJaak PRO

There are two ways to de-install HiJaak PRO: Workstation and Stand Alone /
Network Server. Use the Workstation de-install if HiJaak PRO is running on a
network, and you want to remove only references to it from your Windows .INI
files and Registration Database. To do this, double-click on the HJSetup icon. In
the Install Options dialog box, click on the De-Install button. In the De-install
dialog box, click on the Workstation button. Use the Stand Alone / Network
Server de-install if you want to remove all HiJaak PRO program files as well as
remove HiJaak PRO from your Windows files. To do this, insert HiJaak PRO
Disk 1, run the install program as described earlier in this chapter, select
De-install and click on the Stand Alone / Network Server button. 

Ins talling Import F ilters

If you select Full Install, Network Install, or Custom Install with Application
Interfaces, HiJaak PRO automatically installs import filters for applications that
you select. If you install one of the supported applications after you’ve installed
HiJaak PRO, you will have to install import filters separately. Double-click on
the HJSetup icon in the HiJaak PRO program group. You will see the Install
Options dialog box. Click on Import Filter Install. You will see the Add Import
Filter dialog box. Click on the check box next to the applications to which you
want to add import filters. Adding import filters will modify your application
INI file, your WIN.INI file, or both. Click on OK to install the filters.

Running HiJaak PRO

After installing HiJaak PRO as described above, double-click on the HiJaak
PRO icon. You will see the HiJaak PRO Main screen.

HiJaak PRO Main Screen
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Us ing a Mouse or the Keyboard

HiJaak PRO adheres to the interface standards of Microsoft Windows 3.1.  If
you have Windows 3.1 installed on your system, you may notice that many

dialog boxes are common to your applications.  If you are familiar with other
Windows applications, most of the dialog boxes will be easy to understand.
Throughout this manual, the instructions assume that you are using a mouse.
You can, however, use the keyboard.  The instructions below show you how to
move around in HiJaak PRO using either the mouse or the keyboard.  

Note: You will notice that after you select certain options, the cursor
changes to an hourglass and arrow icon.  This cursor indicates that
although HiJaak PRO is processing your last command (hourglass), it will
still allow you to select other options and commands (arrow).  Your
commands will be executed in the order you give them.  Cancel will only
affect the currently executing process.

To s tart HiJaak PRO from the Program Manager:

MOUSE:  Double click on the HiJaak PRO icon.

KEYBOARD:  To move beween groups, press Ctrl + Tab.  Use the arrow keys to
highlight the HiJaak PRO icon.  Press Enter.

To pull down a menu in HiJaak PRO:

MOUSE:  Click once on the menu you wish to pull down.

KEYBOARD:  Notice the underlined letter on the menu command you wish to
pull down.  Press the Alt key and your letter of choice simultaneously.  
For example, to pull down the File menu, press Alt + F.

To select a pull down menu item:

MOUSE:  Click once on the menu item.

KEYBOARD:  Use the arrow keys to highlight the menu item you wish to select.
Press Enter.  If you pull down the File menu, you will notice the keystroke
combination Ctrl + O to the right of Open.  Such keystrokes are shortcuts that
you can use from anywhere in the program to open a file.  

Installation
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To move around in a dialog box:

MOUSE:  Click once on the area you wish to edit.  If you wish to pull down a
box to scroll through selections, click on the down arrow to the right of the
selection.  If the area is a text-only field, click once in the text entry area, then
type in your text. 

KEYBOARD:  Use the Tab key to move to the area you wish to edit.  Use the
arrow keys to scroll through the selections.

To accept all changes you have made to a dialog box:

MOUSE:  Click on OK.

KEYBOARD:  Press Enter.

To exit a dialog box without accepting changes:

MOUSE:  Click on Cancel.

KEYBOARD:  Press Esc.
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Getting S tarted

This chapter explains basic file operations, such as Open, Save, Print and
Close.  Windows Clipboard Cut, Copy, Copy As, and Paste are also

described. 

Opening the Image You Want to View

HiJaak PRO allows you to open:

q Files

q Windows clipboard images

q Screens you have captured

The following section describes how to open a file.  For information on pasting
from the clipboard, see Windows Clipboard Support later in this chapter.  For
information on screen capture, see Chapter 5: Capturing a Windows Screen.

Note: Throughout this manual, the “ active image”  will be mentioned.  The
title bar of the active image will be highlighted. If you open images on top
of each other, you can only change or edit the active image, which is the
one on top. If you have several images on the screen, you can bring any
image to the top and make it active by clicking on it. If you are using the
keyboard, press Ctrl+Tab to switch active windows.

You can open an image if it is in one of the source formats listed in the table on
the following page.
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Table of S upported Formats

VECT OR RAST ER FAX (Raster)

AI

CGM

DRW
DXF
EPS

GCA
GEM
IGF
MCS
MET

PCT1

PCT2
PIC
PIX
PGL
P10

TXT
WMF
WPG

Encapsulated
 PostScript (dest.  only)
Computer Graphics
 Metafile
Micrografx Draw
AutoCAD
Encapsulated 
 PostScript (dest. only)
IBM GOCA
GEM Metafile
Inset Systems IGF
MathCAD (dest. only)
PM Metafile 
 (dest. only)
Macintosh PICT
 (source only)
Macintosh PICT
Lotus
Inset Systems PIX
HP 7475A Plotter 
Tektronix Plot 10
 (source only)
ASCII Text
Windows Metafile
WordPerfect Graphic

ATT
BMP
CAL
CPR

CUT
DBX
DIB
ED5
EPS

GED
GIF
ICA
ICO
IFF
IGF
IMG
JPG
KFX
MAC
MSP
PCD
PCL4
PCX
PCT1

PCT2
PIX
RAS
SBP

TGA
TIF
WPG

AT&T Group 4
Windows/ OS/2 Bitmap
CALS Raster
Knowledge Access
 (source only)
Dr. Halo
DataBeam
Windows/ OS/2 Bitmap
EDMICS
Encapsulated 
 PostScript (dest. only)
Wicat
CompuServe
IBM IOCA
Windows Icon
Amiga ILBM
Inset Systems IGF
GEM Paint
JPEG
Kofax Group 4
MacPaint
Microsoft Paint
Photo CD
HP LaserJet II
PC Paintbrush
Macintosh PICT
 (source only)
Macintosh PICT
Inset Systems PIX
Sun Raster
IBM Storyboard PIC
 (source only)
Truevision
TIFF
WordPerfect Graphic

F01
301
001
001

001
FAX
FAX
FAX
FAX
TIF
FAX
001
FFF
DCX
OAZ
F01

FAX
001
SCI
001
DCX
F01
001
FAX

AdTech
Brooktrout Fax-Mail
Calculus EZ-Fax
Complete FAX 
 Portable
Complete FAX
Everex EFAX 2
Everex EFAX 3
Frecom FAX96
Fujitsu dexNET
GammaLink
Generic Fax
Hayes JT Fax
JetFax
Intel
Net Fax Manager
Product R&D Fax
 Modem
Relisys TEFAX
Ricoh
SciFAX
SMARTFAX
SpectraFAX
TriGem
WorldPort
Xerox MicroFax
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How to Open a F ile 

Note: Throughout this manual the word "ghosted" will be used to describe
a grayed out selection on the screen.  A selection is ghosted when the
operation is not available.

 1 Pull down the File menu.  Click on Open.  You will see the Open dialog box.

 2 [OPT IONAL] If you would like to use the HiJaak
Browser to search for and open an image, click
on the Browser button.  You will see the HiJaak
Browser Main screen.  See your HiJaak Browser
documentation for more information.

 3 In the Drives area of the dialog box, click once on
the down arrow to pull down the Drives list, then
click on the drive that contains the file you wish
to view. 

 4 In the Directories area of the dialog box, click on
the subdirectory that contains the file.  Notice that
the current directory is shown right under the
word Directories.  To move "up" in the directory
tree, double-click on the level to which you wish
to move.  To move "down" in the directory
structure,  double-click on the subdirectory.  If,
for example, your current directory is C:\HJPRO,

but the file you want to open is in C:\IMAGES,
you would double-click first on C:\, then on the
IMAGES subdirectory.

 5 In the List Files of Type list box, pull down and
select the file type.  The Options button will
become available.  If your file type is on the list,
but your extension is not, see Format Extensions
in Chapter 7: Changing Your Setup.

Step 1: Open dialog box

Step 5: Pull down List Files of Type
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 6 [OPT IONAL]  If  you wish to set options, click on
the Options button.  You will see the Source
Options dialog box.

Auto Scale options are available to all raster
formats, and affect how an image appears in
various scaling situations.  For more information,
see Chapter 3: Changing the Look of an Image.

Other source options available to you will depend
upon the type of file you are opening.  If you
have any questions about specific options on your
screen, click on Help.  You will see a list of
options.  Click on a particular item for more
information.

 7 If you have set options, click on OK to return to
the Open dialog box.  In the File Name area of
the screen, click on the file you wish to open.
Click on OK.  The source image will appear on
the screen.

Note: HiJaak PRO allows you to open multiple images.  In the Open
dialog box, hold down the Ctrl key while you click on the files in the File
Name area that you wish to open.  The images will appear on the screen in
the order in which they appear in the list box.

Note: The image you are viewing may be limited by your Windows
graphics mode.  For example, if you are viewing an image with 256 colors
while running Windows in 16 color mode, you will not be viewing the image
exactly as it is. HiJaak PRO will display the image using the closest
available colors.

Step 6: Source Options dialog box

Step 7: Viewing the Image
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Getting Information on the F ile You Have Opened

To get information on the active image, pull down the File menu and click on
Info.

When HiJaak PRO opens an image, it reads information on the file’s format,
size, and file date.  This information is displayed in the Info dialog box in
addition to width and height in pixels and number of colors if the image is raster,
and vertical and horizontal resolution.  

Note that this information changes only after you change the file, save it, and
open the changed file.

 Saving Your Editing Changes

If you have made changes to an image, you can save them by pulling down the
File menu and clicking on Save.  This will replace your original image with the
edited version.  If you wish to save the image under a new name or format,  pull
down the File menu and click on Save As.  This will create a new file, and your
original image will remain intact.

Clos ing the F ile 

To close the active image, pull down the File menu and click on Close.  To close
all images, pull down the File menu and click on Close All.  If you wish to Exit
at this point, pull down the File menu and click on Exit.
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Printing the View

HiJaak PRO allows you to print the active view.  You can change the position
and size of the image on the printed page.  If you have edited the image, the

edited view will print. If you want to print just an area of the image, you must
first crop it. 

How to Print the View 

 1 Make sure the image you wish to print is on the screen and active. 

 2 Pull down the File menu and click on Print.  You
will see the Print dialog box.

 3 Make sure the appropriate printer has been
specified.  If you wish to select another printer,
click on Setup and specify the printer before
going on to step 4.

 4 For multi-page images, in the Print Range area
click on All to print all pages, or Pages to print a
range of pages.  If you select Pages, enter the
beginning and ending page in the From and To
areas.

 5 If you are printing to a printer that supports adjustable print quality, you
can select High, Medium, or Low print quality in the Print Quality area.  If
your printer does not support these print quality choices, you will see a
dots per inch (dpi) value in this field.

 6 If you are printing to a file, click on Print to File.  If you do this, you will
be prompted for a filename.

Step 2: Print dialog box
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 7 [OPT IONAL] If you would like to select from
available options, click on the Options button.
You will see the Print Options dialog box.  Print
options only change the printed image, not the
display or file.  These options are described
below.  When you have finished selecting
options, click on OK.

 8 Click on OK to print.

Print Options

Note: In the Print Options dialog box, you will see a box representing your
page and within this box, a thumbnail representation of your image.  As you
change size and position, this thumbnail will change in relation to the page.
You may position the image by clicking on the thumbnail and dragging it to
a new position on the page.  You may resize the image by clicking on one of
the sides or corners and dragging.

The following options are available in the Print Options dialog box:

q Fast Print –– To select this option, click on the Fast Print
check box.  Fast Print allows the printer to handle color
processing and scaling of a file, thereby allowing it to print
faster.

q Top and L eft –– HiJaak PRO centers the image on the
printed page by default, but allows you to change that
position.  You cannot position any part of the printed
image off the page.  To change position, use the Top and
Left options.  Click in the Top area and type the number of
units you want the image offset from the top of the page.
Click in the Left area and type the number of units you
want the image offset from the left side of the page. 

q Center –– Click on the Center button to reset the image
in the center of the page.

Step 7: Print Options dialog box
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q Maximum Height and Width –– By default, HiJaak
PRO prints your image 7" tall by 5" wide, but allows you
to change the size by specifying height and width for the
printed image. You cannot make the image larger than the
page. To change width, click in the Maximum Width area
and type a new width for the image. To change height,
click in the Maximum Height area and type a new height
for the image.  

Note: HiJaak PRO maintains the aspect ratio of the image when you
change its height or width.  This means if you have an image 2 inches tall
and 2 inches wide, you can only change the size to 1 by 1, 3 by 3, 4 by 4,
etc.  If you want to change the aspect ratio, click in the Distort Aspect Ratio
check box.  You will then be allowed to resize the image any size smaller
than the page size, but the image will be distorted.

The following options are also available and are described in 
Chapter 3: Changing the Look of an Image.

q Units

q Smoothing

q Grayscale

q Colors to Black

q Reverse Black and White

q Invert Colors

q Reveal Background Color Objects

q Contrast/Brightness...

q Reduce Colors...

q List Color Changes...

q Rotate...

q Curve Quality
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Windows Clipboard Support

HiJaak PRO allows you to cut, copy, and paste images between HiJaak PRO
and the Windows Clipboard.  

You can cut or copy to the Clipboard and open another application without
closing HiJaak PRO.  Then, when you paste in that application, HiJaak PRO will
provide the image in the format requested by the pasting application.  This
process is called delayed rendering.  You can also copy an image to the
Clipboard in one of several formats of your choice.  If you cut or copy an image,
and then attempt to exit HiJaak PRO, you will be asked in what format you wish
to save the Clipboard image. 

How to Cut an Image to the Windows Clipboard

 1 Pull down the Edit menu and click on Cut.  

 2 The current image will be copied to the Windows Clipboard and the
current HiJaak image window will close.

How to Copy an Image to the Windows Clipboard

 1 Pull down the Edit menu and click on Copy.  

 2 The current image will be copied to the Windows Clipboard and the
current HiJaak image window will remain open.
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How to Copy an Image to the Windows Clipboard
in a S elected Format.

 1 Pull down the Edit menu and click on Copy As.  You will see the Select
Clipboard Format dialog box.

 2 You can select a raster format if your file is a
raster image, and a vector or a raster format if
your file is a vector image.  Click on a format
appropriate for your image.

 3 Click on the Options button to select processing
options.  For information on processing options,
see Chapter 3: Changing the Look of an Image.

 4 Click on OK.  The current image will be copied to
the Windows Clipboard in the format that you
selected, and the current HiJaak PRO window will
remain open.

Note: HiJaak PRO registers the image when you cut or copy to the
clipboard.  "Registering" means that HiJaak PRO becomes ready to convert
the image to any HiJaak-supported format requested by the pasting
application.  If you exit HiJaak PRO directly after a copy or cut, you will
see the Select Clipboard Format dialog box, just as if you had selected
Copy As.  Select the format to use for rendering and click on OK.  HiJaak
PRO copies the image to the clipboard and exits.

How to Paste into HiJaak PRO from the Windows Clipboard

 1 Make sure that an image is available in the Windows Clipboard.

 2 Pull down the Edit menu and click on Paste. 

 3 HiJaak PRO will create a new image window, titled "Paste," and paste the
clipboard image there.  

 4 To give the image a name, pull down the File menu and click on Save As. 

Step 2: Select Clipboard Format
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Us ing Command L ine Mode

Viewing an Image from the Command L ine

HiJaak PRO has a utility that allows you to view an image from the command
line.  The advantage of this method is that it is quick if you know the path of the
file you wish to view.

How to Open an Image Using the Command L ine

 1 From the HiJaak PRO Main screen, pull down the File menu and click on
Command.  You will see the Command dialog box.  

 2 Type the path and name of the file you wish to
view.  All wildcards that you can use in DOS, you
can use to view from the command line.  For
example, if the file you want to view is
IMAGE.PCX, in the picture directory on the d:
drive, then you should type:

   d:\picture\image.pcx

 3 Click on OK.

Note: You can also use command line mode from Windows Program
Manager by pulling down the File menu and clicking on Run.  Then type
hjpro followed by the command line as described in step 2.

Step 1:  Command Dialog Box
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Printing a F ile F rom the Command L ine

How to do Command L ine Batch Printing

 1 Click on either the Run command in the Windows Program Manager or the
Command selection on the HiJaak PRO File menu. 

 2 Type HJPRO [source filename] PRN.  All
wildcards that you can use in DOS, you can use to
print from the command line. The complete
syntax for command line printing is:

HJPRO  [path/source.ext] PRN 

For example, if you want to print all the BMP
files in the root directory of the C drive, you
should type:

HJPRO  c:\*.bmp prn 

 3 Click on OK.

Note: When using the HiJaak PRO Command Line, use of HJPRO as part
of the command is optional.

Step 2: Printing files from the Program
Manager
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Changing the Look of an Image

You can use HiJaak PRO to view and edit images. You might want to view an
image before converting it –– to make sure that it looks as you expect it to

look. You can also edit and process the image.  In HiJaak PRO, “editing” means:

o Cropping

o Rotating

o Changing size

o Changing fonts in a vector image

“Image Processing” refers to the features that change image quality, such as
contrast, brightness, and palette optimization. HiJaak PRO also allows you to
change colors in your image.  You can view, edit, and process your images if
they are stored in any of the source supported formats listed in Chapter 2:
Getting Started.
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Changing the View

Notice that when you place the cursor over an open image and press the
mouse button, the cursor changes to a magnifying glass.  When you see the

magnifying cursor, hold the mouse button, drag the mouse, and release the
button to zoom in on a particular area of the image. The image below shows a
zoomed in view of the example image.  

As you change and resize the image, HiJaak PRO will resize the image without
distorting it or adding any white space to it.  If you wish to stretch the image as
you stretch its window, you should select the Auto Scale option as described
later in this chapter.  

Note: Some images have a white border.  HiJaak PRO will not add any
white space to that border, but it will be visible when you view the image.
Some example images in this manual have this type of border.

Note: Changing the view will change the display without changing the
file. Editing the image and working with colors in the image will change the
display and change the file once you save it.  Editing and working with
colors are described later in this chapter.

To change the view, pull down the View menu.  HiJaak PRO allows you to
change the view in the following ways:

o Zoom In  –– zoom in on a part of the image that you
specify.

o Zoom Out  –– zoom out (if you have loaded a large
image) or zoom back out after you have zoomed in.

Zoomed In Image
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o Zoom 1 to 1  –– reset the scale factor back to 100%.

o Auto Scale –– resize the image to fit in the window, in
the width of your screen, or to maintain its original size as
you change the window size.

o Center View  –– see the image centered around a point
you select.

o Image Only  –– see the image alone on the screen.

o Clone  –– create a new window identical to the current
image window.

Each of these viewing options is described in detail below.  

How to Zoom In

 1 Make sure the image you wish to zoom in on is on the screen and active.  

 2 Pull down the View menu and click on Zoom In.
You will see a side menu. 

 3 Click on 2x, 4x, or Custom.  If you click on 2x,
the image will become two times larger with the
center point maintained.  If you click on Custom,
click and drag the mouse to define the custom
area you wish to enlarge.  To “undo” the zoom,
click the right mouse button once or press Esc.

Step 2:  Zooming In

C
h

an
g

in
g

 t
h

e 
L

o
o

k 
  

Changing the Look 3-3



How to Zoom Out

 1 Make sure the image you wish to zoom out on is on the screen and active.  

 2 Pull down the View menu and click on Zoom
Out.  You will see a side menu allowing you to
zoom out to make the image two times smaller,
four times smaller or Fit in Window.  If you
select Fit in Window,  HiJaak PRO will zoom out
until the uncropped image fills the window.

 3 Click on 2x, 4x or Fit in Window.  To “undo”
zoom out, place the cursor over the image and
click the right mouse button once or press Esc.

How to Reset the Image to a Scale Factor of One

When you zoom in or out on an image, the scale factor changes.  To reset the
scale factor back to 100%:

 1 Make sure the image you wish to reset is on the screen and active.

 2 Pull down the View menu and select Zoom 1 to 1 (100%).  The image
scale factor will be set to 100%.  Your Auto Scale option will be set to Off.
For more information on auto scaling, see below.

Note: Whenever you view a raster image, a scaling factor indicating
percent scaled will appear in the image title bar next to the image name.
For information on raster images, see Chapter 4: Converting a File from
One Format to Another.

Step 2:  Zooming Out
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How to Scale the View

HiJaak PRO allows you to select how the image will appear on the screen in
various scaling situations.  Aspect Ratio will not be distorted in any of these
scaling options.

 1 Pull down the View menu and click on Auto Scale.  

 2 You will see a side menu with the following items: Off, Scale to Window,
and Page in Width.  Click on the scaling option you want to use.  A check
will appear next to the selected item.

o Off––  This option may restrict your view
of certain portions of the image as the
window size and shape are changed.
This option is useful if you wish to avoid
any scaling of your image.

o Scale to Window––  This option allows
images to fit in the Main window when
the Main window size is changed, with
the viewed portion scaling to the window.
It is useful if you want to view the entire
image in your Main window.  Scale to
Window requires additional processing
time over the Off selection.

o Page in Width––  This option allows
images that are normally larger than your
Main screen to view in the width of your
screen.  It is useful if you are viewing
faxes or other page oriented images.
Page in Width requires additional
processing time over the Off selection.

Step 2:  Scaling 
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How to Center the View

To change how a viewed image is centered:

 1 Make sure the image you wish to center is on the screen and active.  

 2 Pull down the View menu and click on Center View.  

 3 Position the mouse cursor at the point around which you want the image to
be centered. Double-click the left mouse button.  HiJaak PRO will re-draw
the image around the center point you have specified. 

Note: Because HiJaak PRO will not put white space around images, if you
position the center point near an edge, the center point will be adjusted to
ensure that the view will not go beyond the edge of the image.

How to Make the Image Appear Alone on the Screen

To see your image full-screen without the frame, title-bar, menu, and status bar:

 1 Pull down the View menu and click on Image Only.  You will see the
image full-screen.  

 2 To return to HiJaak PRO, click the mouse button
once or press the Esc key.

Step 1: Image Only
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How to Create a Clone of the Current Image

You might wish to clone an image if you are experimenting with image
processing options.  For example, you might open an image and make a few
editing changes.  If you then decide to experiment with changing contrast, for
example, you can clone the image and use the clone as a test image.

 1 With the image you want cloned active, pull down the View menu and
click on Clone View.

 2 HiJaak PRO will create a second window which
also contains the current image.  The title bar will
be the same as the original, with a ":" and a
number appended to it.  If, for example, your
original image was GOLDN256.IFF, then your
cloned image would be GOLDN256.IFF:2.  Click on
the title bar of the image to make it active.  If you
are using the keyboard, press Ctrl + Tab.

Step 2: Cloned Image
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Viewing Multi-page Images

If you are viewing a multi-page image, you can move to the next or previous
page using the keyboard.  The Page Up and the Page Down keys let you move

through the multi-page image.  The Ctrl + Page Up and Ctrl + Page Down keys
let you move to the top of the previous page, and to the top of the next page
respectively.  The Home key brings you to the top of the current page.  The End
key brings you to the bottom of the current page.  The Ctrl + Home and Ctrl +
End keys bring you to the top of the first page and the bottom of the last page,
respectively.

Editing the View

So far in this chapter, all options have changed the view without changing the
file.  "Editing" allows you to change the file and thus make the changes

permanent.  For example, you may want to crop an image or change a color
before converting an image.  The editing options allow you to do this.

Important: HiJaak PRO has “sticky” editing features.  This means if you
change the color or the font in a file of a particular format, when you open
other files of that format or convert to that format, those changes will
“stick” - or be done automatically.  If you do not want the changes to affect
subsequent editing or conversion sessions, you should use a special
custom-made "set file."  For more information on set files, see Loading and
Saving Set Files in Chapter 7: Changing Your Setup.

HiJaak PRO allows you to edit the view in the following ways:

o Crop  –– clips the image to a rectangular area that you
specify.

o Rotate –– rotates the image from 0 to 360 degrees.

o Resize –– allows you to change the size of raster images.

o Change a Font  –– allows you to change text fonts in
vector images.

o Undo  –– undoes the last editing operation you performed.

o Undo All  –– undoes all editing operations you performed
on a vector image.
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How to Crop an Image

 1 Pull down the Edit menu and click on Crop.  The cursor changes to the
scissors icon.  If you choose to cancel this function now, press the Esc key.
Your cursor changes back to the arrow icon.

 2 Move the mouse cursor to any corner of the area
you wish to crop. 

 3 Click and drag the mouse to define the area you
wish to keep after cropping. 

 4 When you let go of the mouse button, the area
outside the boundary you have defined will be
removed.

Step 3: Defining the Crop Area

Step 4: The Cropped Area
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How to Rotate an Image

 1 Pull down the Edit menu and click on Rotate.  You will see the Rotation
Options dialog box.

 2 In the Type of Rotation field, click on Absolute
or Incremental.  Absolute rotates the image from
point zero.  Incremental rotates the image from its
current location.  For example, suppose you have
rotated an image 90 degrees.  After viewing it,
you decide you would like to view it at 270
degrees.  If you have Absolute selected, you will
need to enter 270 into the Rotation field.  If you
have Incremental selected, you will need to enter
180 into the Rotation field –– 90+180=270.

 3 In the Direction field, select Clockwise or
Counterclockwise. 

 4 In the Rotation field, click on 0, 90, 180, or 270
degrees, or enter a number between 0 and 360.
The number of degrees you choose depends on
what Type of Rotation you select and what
Direction you select. 

 5 Click on OK to rotate your image.

Step 1: Rotation Options Dialog Box

Step 5: The Rotated Image
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How to Resize an Image

You can only change the size of your image if it is a raster image.  Resizing the
image will change both the view and, upon saving, the actual image.

 1 Pull down the Edit menu and click on Resize. You will see the Resize
dialog box

 2 Type in your sizing options. Each option is
described below.

 3 Click on OK.

UNITS: Units are the unit of measure you are specifying when entering a
number elsewhere in the dialog box.  Pixel units are a measure of the number of
dots (pixels) in the raster image.  Use Multiple units if you want an output image
that contains an even multiple of the number of pixels in the source image.
Selecting Multiple will prevent certain image scaling side effects, such as moire
patterns.  

To specify the unit of measure you want to use, click on either Inches,
Centimeters, Pixels, or Multiples in the Units area of the dialog box.  

SCALING:  If you want to specify the dimensions of your destination file, you
must select scaling. To specify the type of scaling you wish to use, click on the
down arrow to the right of Scaling.  Click on one of the following scaling
choices.

o Maintain Aspect Ratio ––   This option is the default.
HiJaak PRO reads the height you enter and then caculates
the width without distorting the aspect ratio. Or, HiJaak
PRO reads the width you enter and calculates the height
without distorting aspect ratio.

Step 1:  Resize Options dialog box
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o Fit in Frame ––  Select this if your destination file must
fit into a specific height and width (or "frame") without
distorting the image. HiJaak PRO reads the height and
width you enter in the height and width fields and then
makes the file fit inside this frame without distorting the
aspect ratio.

o Fit in Width ––   Select this if your destination file must
fit into a specific width. HiJaak PRO reads the width you
enter in the width field and calculates the height for your
destination file without distorting the aspect ratio. 

o Fit in Height ––  Select this if your destination file must
fit into a specific height. HiJaak PRO reads the height you
enter in the height field and calculates the width for your
destination file without distorting the aspect ratio. 

o Distort To Frame ––  Select this if your destination file
must fit into a specific height and width (or "frame") even
if the image distorts. HiJaak PRO reads the height and
width you enter and then makes the image fit into this
frame by distorting the aspect ratio, if necessary. 

o Distort Aspect Ratio ––  Select this if you wish to
distort aspect ratio. Then set the Distort Aspect option.  

o Fit in Display –– Select this if you want your image to
match the size of your display.  For example, if your
display is 640x480 and you select this option, your image
will become 640x480, regardless of its original size.
HiJaak PRO distorts aspect ratio if necessary.  Note that
you will not be able to view the entire image in the HiJaak
PRO Main screen.

o Fit in Display Width ––  Select this if you want your
image to fit in the width of your display.  HiJaak PRO will
calculate the height without distorting the aspect ratio.
Note that you will not be able to view the entire image in
the HiJaak PRO Main screen. 

o Fit in HiJaak Window ––  Select this if you want the
entire image to view in the HiJaak PRO Main screen.
Aspect ratio will be maintained.
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o Fit in HiJaak Width –– Select this if you want the
image to view in the width of the HiJaak PRO Main screen.
HiJaak PRO will calculate the height without distorting the
aspect ratio.

SMOOTHING: Smoothing reduces the jagged appearance of diagonal edges
created during scaling of a raster file.  To select this option, click on the
Smoothing check box.

MAXIMUM WIDTH: Before setting this option, set the Units option, then set the
Scaling option.  Either Height or Width options can become ghosted depending
on what you set for scaling.  

To specify this option, enter the width you want your image to be.  The unit of
measure will be the one you specified in the Units area of the dialog box.

Note:  MAC Paint files are a fixed size and cannot be changed.

MAXIMUM HEIGHT:  Before setting this option, set the Units option, then set
the Scaling option.  Either Height or Width options can become ghosted
depending on what you set for scaling.  

To specify this option, enter the height you want your image to be.  The unit of
measure will be the one you specified in the Units area of the dialog box.

DISTORT ASPECT: Before setting Distort Aspect, you must specify Distort
Aspect Ratio in the Scaling area of the dialog box. 

To specify this option, enter a number in the field.  Entering a number greater
than 1 will distort the image’s aspect ratio by making it wider.  Entering a
number that is less than 1 will distort by making it taller.  For example, entering
2 would make the image twice as wide, whereas entering .5 would make it twice
as tall.

HORIZONTAL RESOLUTION: Since this option requires you to enter a unit of
measure, set the Units option before setting this option. You will only be able to
set resolution if the unit of measurement you choose is either inches or
centimeters. 

To specify this option, enter the horizontal resolution of your destination file.
This will be in either Dots Per Inch (DPI) or Dots Per Centimeter (DPCM)
depending on the unit you have selected. If the units selected are pixels or
multiples, then the resolution field is ghosted.
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VERTICAL RESOLUTION: Since this option requires you to enter a unit of
measure, set the Units option before setting this option.  You will only be able to
set resolution if the unit of measurement you choose is either inches or
centimeters. 

To specify this option, enter the vertical resolution of your destination file.  This
will be in either Dots Per Inch (DPI) or Dots Per Centimeter (DPCM) depending
on the unit you have selected. If the units selected are pixels or multiples, then
the resolution field is ghosted.

How to Change Fonts in an Image

You can only change fonts if your image is a vector image or a DOS text screen
capture.  To see if your image is in a vector format, see the table of HiJaak
PRO-viewable formats at the beginning of Chapter 2: Getting Started, or pull
down the File menu and click on Info.  If no fonts can be changed in an image,
the Change a Font selection is ghosted.

You can change fonts to any TrueType font you have installed.  See your
Windows manual for instructions on the installation of TrueType fonts.

You cannot change any DOS text screen capture fonts to TrueType fonts.

 1 Make sure that the image you wish to edit is open and active.

 2 Pull down the Edit menu and click on Change a Font.  The cursor changes
to a pointing finger and selectable text is framed.  If you choose to cancel
this function now, press the Esc key.  The cursor changes back to the arrow
icon.

Note: It is important to understand that letters and numbers may not be
described as text in the graphics file, but rather as lines and curves.
HiJaak PRO can only select text that is described as text in the graphics file. 
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 3 Move the cursor to a letter that has the font you
wish to change and click the mouse to select it.
Throughout the image, all text with this font is
framed, and the selected text is surrounded by
handles.   

 4 If you want, you can click on and drag the
handles to change the width and height of the
selected font throughout the text.  For example, if
you increase the height of the text by 20%,
throughout the image, all text in this font will
increase in size 20%.  

 5 To change the font, click once on the selected
text.  You will see the Font Selection dialog box.

Note: If you are editing a DOS text screen capture, you will see a Source
Options dialog box instead of the Windows Font Selection dialog box.
Click on Help if you need help with this dialog box.  

 6 Click on any font in the Windows Font Selection dialog box.

 Warning:  Before clicking on OK to accept your changes, consider that
after you save, every time you convert to or from the format of the image
you are editing, the font changes you have just made will be done
automatically.  This is because of HiJaak PRO’s sticky ediying feature. For
example, if you increased a font size by 30% in a CGM image, this change
would be made automatically the next time you Open, Convert, or Save As
in the CGM format. To avoid this, save settings in a set file and click on the
Defaults button in the Load Setttings dialog box.  To learn how to save set
files, see Loading and Saving Set Files in Chapter 7: Changing Your Setup.

 7 To save your font changes, click on OK.   

Step 3: Selecting the Font to Change

Step 4: Changing the Size of Selected Font
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How to “Undo” the Last Editing Operation You Performed

 1 Pull down the Edit menu.  Click on Undo to reverse the effect of the most
recent editing operation.

 2 If available, use repeatedly to erase the editing operations you have
performed in reverse order.  If this type of reverse-editing is not available,
the Undo command will change to Redo.

Note: To Undo all the viewing and editing changes you have made in an
editing session, pull down the Edit menu and click on Undo All.  Your image
will view as it did when you first opened it.  The Undo All option is only
available to vector files.  

Working with Colors 

HiJaak PRO allows you to manipulate colors in an image.  Like editing,
manipulating colors will change both the view and the file.  Also like

editing, most color operations may be undone with the Edit menu’s Undo
command. 

HiJaak PRO allows you to manipulate colors in the following ways:

o Change a Color –– allows you to change any color in
an image.

o List Color Changes ––  allows you to verify and edit
any color changes you have made.

o Contrast and Brightness ––  allows you to manipulate
light and dark areas of the image.

o Reduce Colors –– allows you to increase or decrease
the number of colors in the image.

o Grayscale –– forces all colors in the image to shades of
gray.

o All Colors to Black –– forces all colors in the image to
black.

o Reverse Black and White –– replaces all black in an
image with white, and all white with black.
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o Invert Colors –– inverts all colors in an image, creating
a "negative."

o Reveal Background Color Objects –– inverts the
color of objects that are the same color as the background,
and thereby reveals them.

How to Change Specific Colors in an Image

 1 Make sure that the image you wish to edit is open and active.

 2 Pull down the Colors menu and click on Change
a Color.  The cursor changes to the eye dropper
icon.  If you choose to cancel this function now,
press the Esc key.  The cursor changes back to the
arrow icon.

 3 Move the cursor to the color you wish to change
and click the mouse to select. You will see the
Color dialog box.

 4 [OPTIONAL] If you want to define a custom
color, click on the Define Custom Colors button.
The dialog box will expand and you will see a
color refiner box and a luminosity bar.  Drag the
cursor in the color refiner box and on the arrow
beside the luminosity bar to define your color.

You can also change colors by typing values into
the Red, Green and Blue boxes, or the Hue, Sat
(saturation), and Lum (luminosity) boxes.

The color you create is shown in the left side of
the Color/Solid box.  Double-click on the right
side of the box to use the solid color closest to the
one you have created.

Click on Add to Custom Colors.  You will see the
color you created in the Custom Color Palette.  

Step 3: Color Dialog Box

Step 4: Define Custom Colors
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 5 Click on the replacement color.

 6 Click on OK.  Every place the selected color appears in the image, it will
be replaced with the replacement color.

Note: If the image in which you are trying to change a color has more
colors than your display, you will not be able to see all the actual colors in
the image.  Therefore, what appears as a solid white, may actually
represent a dithered pattern of several shades of white.  Keep this in mind if
the Change a Color item does not change colors in your image everywhere
you expect it to.  

How to Verify and Edit Your Color Changes

You can see, modify, or delete the color changes you have made.  To do this,
pull down the Colors menu and click on List Color Changes.  You will see a list
of the color changes that have been made to  the currently active image.  This
includes "sticky" changes.  If you want, you can modify the changes by clicking
on Modify, or start over by clicking on Clear.

To apply all the color changes to the active image, click on the Apply Color
Changes check box.

Figure 1: List Color Changes 
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How to Adjust Brightness and Contrast

HiJaak PRO allows you to increase or decrease the differences among light and
dark colors in an image. Contrast and Brightness and related options are similar
to those that would be available to someone developing photographs in a
darkroom.  To adjust lights and darks in your image, pull down the Colors menu
and click on Contrast and Brightness.  You will see the Contrast and Brightness
dialog box. The following options are available:

o Contrast

o Brightness

o Gamma Correction

o Histogram Equalization

You will see the thumbnail representation of your image change dynamically as
you change the values of these options.  Each option is described in detail below.

CONTRAST: Increase the Contrast to make light colors lighter and dark colors
darker. Decrease the Contrast to make light colors darker and dark colors lighter.

To set Contrast, click on the scroll bar next to Contrast, or type a value into the
Contrast field.

BRIGHTNESS: Modify this option if you want to either lighten or darken your
image.

To set Brightness, click on the scroll bar next to Brightness, or type a value into
the Brightness field.

GAMMA CORRECTION: Increase Gamma Correction to increase brightness in
the midrange areas, while leaving the dark and light areas alone.  Decrease
Gamma Correction to decrease brightness in the midrange areas, while leaving
the dark and light areas alone.

To set Gamma Correction, click on the scroll bar next to Gamma Correction, or
type a value into the Gamma Correction field. 

Figure 2: Contrast and Brightness
Dialog Box
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HISTOGRAM EQUALIZATION: Select this option if you want to bring out detail
in an image that appears to be basically the same color, or colors, throughout the
image.  To bring out detail, histogram equalization analyzes the colors in the
image.  Colors that are very close in value (i.e. they look very similar) are
distributed over the spectrum of colors in the image. 

To select Histogram Equalization, click on the Histogram Equalization check
box.  When you select Histogram Equalization, the Contrast, Brightness and
Gamma Correction options are disabled.

How to Reduce or Increase the Number of Colors

Use this option to specify how colors will appear in your image.  To change the
number of colors in an image, pull down the Colors menu and click on Reduce
Colors.  You will see the Reduce/Expand Colors dialog box.  The following
options are available:

o Number of Colors

o Reduction Method

o Screen Frequency

o Optimize Palette

Each option is described in detail below.

NUMBER OF COLORS: This option allows you to select how many colors will
appear in the image.  Use this option if you are converting an image with many
colors to one with fewer colors, or vice versa.  If the number of colors is
reduced, a reduction method should be specified.  

If you are converting a file, the number of selections available will depend on
the type of destination file you have selected.

To specify this option, click on the desired number in the Number of Colors area
of the dialog box. 

Figure 3: Reduce Colors Dialog Box
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REDUCTION METHOD: Use this option to specify which color reduction
method HiJaak PRO should use to create the file.  You have a choice of Snap,
Halftone, Dither, or Diffuse.  These are described below.

o SNAP –– This is the quickest method.  Essentially, HiJaak
PRO reads each pixel in the source file and matches the
color as closely as possible using the destination format’s
palette.  This works well if your source image has a wide
range of colors, and the adjacent dots are well
differentiated.  You will probably not want to use this if
you are converting a file with many colors to a file with
few colors.

o HALFTONE–– This method, as well as Dither and Diffuse,
is often used when converting a color file for output on
a black and white device (like a black and white laser
printer).  Halftone, Dither, and Diffuse all attempt to
simulate colors with patterns representing different levels
of gray.  Halftone simulates gray by varying the placement
and grouping of each dot (pixel) on an invisible grid.  The
more dots in a certain area on the grid, the darker the
shade.  You can see this variation under a magnifying
glass. In Halftone the groupings are dots, in Dithering the
groupings are a more intermixed pattern.  The Halftone
method generally produces the best black and white
printed image.

o DITHER –– This method creates patterns for each color or
shade of gray.  These patterns are repeated in the image
each time that particular color or shade of gray is needed.
Sometimes these patterns are visible and they can become
distracting.  If this happens, you may want to try Diffuse.

o DIFFUSE –– This method is similar to the Dither method
except that the patterns change (or diffuse) gradually
across the image.  Generally, Diffuse will produce the best
displayed image.  This means that you are less likely to
notice a repeating pattern.  The downside of this method is
that “worming” patterns can appear in a local area.
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OPTIMIZE PALETTE: Select this option if you are reducing the number of
colors in an image, and you want  HiJaak PRO to select colors for the destination
image closest to those in your original image.  For example, if your source
image was a close-up of a red rose, HiJaak PRO would select a palette with a
variety of reds for the image.  

To select  this option, click on the Optimize Palette check box.

Hint: If you have an all-gray image, you probably should not use Optimize
Palette.

SCREEN FREQUENCY:  You may only modify the Screen Frequency option if
you have selected Halftone as your color reduction method.  Screen Frequency
is measured in Lines per Inch (LPI).  Resolution (horizontal and vertical) and
screen frequency are related to the number of grays produced in your output.
The formula for this is as follows:

GRAY LEVELS = (RESOLUTION / SCREEN FREQUENCY)2

For example, if you have a 300 Dot Per Inch (DPI) resolution printer, and you
set your screen frequency to 150 LPI, your printer output will have 4 grays.  If
you change your screen frequency to 75 LPI, your printer output will contain 16
grays but will produce a coarser grain than the first example.  If you want more
grays with a fine grain, increase the resolution by printing out to an imagesetter
with high resolution (1200 DPI or higher). 

When you select Halftone as the color reduction method, Screen Frequency
controls the size of the half-tone screen.  A coarser screen will show more gray
tones but less edge crispness.

If you do not set screen frequency, then HiJaak PRO automatically detects a
screen frequency for your image.  This auto-detect feature usually yields the best
results.  If you do set Screen Frequency, then you should set Horizontal and
Vertical resolution of your file to match your output device.
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How to Make the Image Gray

To force the image to a grayscale with the same number of grays as colors were
in the image, pull down the Colors menu and click on Grayscale.  A check
appears next to that menu item, and your image immediately becomes a
grayscale.

How to Make the Image Black and White (Monochrome)

 1 Pull down the Colors menu and click on Reduce Colors.  You will see the
Reduce/Expand Colors dialog box.

 2 In the Number of Colors area, click on Black and
White (2).

 3 If you have a high contrast image, such as a text
screen capture, click on the Snap radio button in
the Reduction Method area.  If you have an image
with many colors and you want simulated grays,
select Dither in the Reduction Method area.

 4 Click on OK.  The image becomes solid black
and solid white.

Note: This effect, creating an image with solid colors of the number you
specify, is also known as posterization.  You can posterize any image by
reducing the number of colors, for example, from 256 to 16, and selecting
Snap in the Reduction Method area.

How to Force all Colors to Black

The All Colors to Black option is useful if you have an image with very light
foreground colors and a white background, and you want to print it. In this case,
this option forces all colors to black and leaves white areas alone, which yields
good results when printing. All Colors to Black is most commonly used for
printing CAD drawings on black and white printers, because it forces lines to
appear as solid black rather than as dithered gray.

This option is also useful if you have a 2-color DOS text screen capture in which
the colors are similar. In this case, All Colors to Black analyzes the image and
forces the lighter color to white, and the darker color to black.  

To force all colors in an image to black, pull down the Colors menu and click on
All Colors to Black.

Step 4: The Black and White Image
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How to Reverse Black and White in an Image

 1 Make sure the image you want to process is open and active.

 2 Pull down the Colors menu and click on Reverse Black and White.  All
black in the image becomes white, and all white becomes black.

How to Invert Colors in an Image

Select this option if you want to create a "negative" of the original image.  

 1 Make sure the image you want to process is open and active. 

 2 Pull down the Colors menu and click on Invert.
All colors in the active image will be inverted.

How to Reveal Hidden Objects

When a vector image contains objects – lines, circles, etc. – that are the same
color as the background, those objects become hidden.  In order to reveal these
hidden objects, with the image open and active, pull down the Colors menu and
click on Reveal Background Color Objects.  HiJaak PRO inverts the color of the
hidden objects and thereby reveals them.

Step 2:  The Inverted Image
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Converting an Image from One Format to Another

HiJaak PRO allows you to convert to and from any of over 70 formats.  If
you have a file that you wish to bring into one of a number of popular

software applications, you may want to let HiJaak PRO select the destination
format that will successfully import into your application.  When using the
Convert To or the Save As methods of conversion (described later in this
chapter), click on the Applications button in either the Save As or Convert To
dialog boxes.  Destination file options are also available from these dialog
boxes.  These processing options are explained at the end of this chapter. 

Introduction to Vector and Raster F ile Formats

There are two general types of graphics file formats: vector and raster. Vector
images consist of drawing objects, such as lines, circles, and squares. Vector

images can also contain text with font information that, unlike raster text, can be
changed using HiJaak PRO’s Change a Font feature.  Vector images are usually
created by CAD, drawing, charting, or graphing software applications.

Raster images consist of thousands of dots, called pixels, that are arranged in a
rectangle called a bitmap. Raster images are usually created by scanners or paint
software applications.  All fax formats are raster.  

Metafiles are a third graphics file format type, containing both raster and vector
components.  In the following conversion rule, HiJaak PRO treats metafiles like
vector files.

Using HiJaak PRO you can convert from and to the following:

q a VECTOR file format to a VECTOR file format

q a VECTOR file format to a RASTER file format 

q a RASTER file format to a RASTER file format
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You cannot convert from and to the following:

q a RASTER file format to a VECTOR file format.

For best results, convert metafile formats to raster formats.  If you attempt to
convert a metafile to a vector format, you may succeed in converting only a
portion of the original image or none of the image at all.  This is because
metafiles may contain both raster and vector components, and HiJaak PRO
cannot convert raster information to a vector format.

Before converting a file, check the following lists of HiJaak PRO-supported
RASTER and VECTOR formats to make sure you are not trying to convert from a
RASTER to a VECTOR format.
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Table of S upported Formats

VECT OR RAST ER FAX (Raster)

AI

CGM

DRW
DXF
EPS

GCA
GEM
IGF
MCS
MET

PCT1

PCT2
PIC
PIX
PGL
P10

TXT
WMF
WPG

Encapsulated
 PostScript (dest. only)
Computer Graphics
 Metafile
Micrografx Draw
AutoCAD
Encapsulated 
 PostScript (dest. only)
IBM GOCA
GEM Metafile
Inset Systems IGF
MathCAD (dest. only)
PM  Metafile
 (dest. only)
Macintosh PICT
 (source only)
Macintosh PICT
Lotus
Inset Systems PIX
HP 7475A Plotter 
Tektronix Plot 10
 (source only)
ASCII Text
Windows Metafile
WordPerfect Graphic

ATT
BMP
CAL
CPR

CUT
DBX
DIB
ED5
EPS

GED
GIF
ICA
ICO
IFF
IGF
IMG
JPG
KFX
MAC
MSP
PCD
PCL4
PCX
PCT1

PCT2
PIX
RAS
SBP

TGA
TIF
WPG

AT&T Group 4
Windows/ OS/2Bitmap
CALS Raster
Knowledge Access
 (source only)
Dr. Halo
DataBeam
Windows/ OS/2 Bitmap
EDMICS
Encapsulated 
 PostScript (dest. only)
Wicat
CompuServe
IBM IOCA
Windows Icon
Amiga ILBM
Inset Systems IGF
GEM Paint
JPEG
Kofax Group 4
MacPaint
Microsoft Paint
Photo CD
HP LaserJet II
PC Paintbrush
Macintosh PICT
 (source only)
Macintosh PICT
Inset Systems PIX
Sun Raster
IBM Storyboard PIC
 (source only)
Truevision
TIFF
WordPerfect Graphic

F01
301
001
001

001
FAX
FAX
FAX
FAX
TIF
FAX
001
FFF
DCX
OAZ
F01

FAX
001
SCI
001
DCX
F01
001
FAX

AdTech
Brooktrout Fax-Mail
Calculus EZ-Fax
Complete FAX 
 Portable
Complete FAX
Everex EFAX 2
Everex EFAX 3
Frecom FAX96
Fujitsu dexNET
GammaLink
Generic Fax
Hayes JT Fax
JetFax
Intel
Net Fax Manager
Product R&D Fax
 Modem
Relisys TEFAX
Ricoh
SciFAX
SMARTFAX
SpectraFAX
TriGem
WorldPort
Xerox MicroFax

C
on

ve
rt

in
g 

Im
ag

es

Converting Images 4-3



T he T hree F ile Convers ion Methods

HiJaak PRO allows you to convert a file using three methods: the Open then
Save As method, the Convert method, and the Command Line method. A

description of each is given below. Choose the method that suits your needs.
Step-by-step instructions are given later in this chapter.

When to Use the Open then S ave As Method 

Use this method if you want to view the image as it is before you convert it.
Certain interactive editing options, such as cropping, font changes, and color
changes are accessible through this method.  

When to Use the Convert Method 

Use this method if you want the option of converting either the file you are
currently viewing, or any other file on the disk.  If you choose to convert the file
you are viewing, the procedure will follow the Open then Save As method.
Converting a file on disk without first opening it is the faster method.

When to Use the Command L ine B atch Method  

Use this convert method if speed is of primary importance.  It allows you to
quickly convert a file from Windows without bringing up the HiJaak PRO Main
screen. It also allows you to use DOS wild cards to convert in batches.

Do not use this method if you need to view the image you want to convert, or if
you need to edit the file.  To change default options, you must attach a
pre-existing set file.  For more information on set files, see Chapter 7: Changing
Your Setup.
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Open then S ave As Method

How to Open the F ile You Wish to Convert

Note: In this manual, the source file is the file you wish to convert.  The
destination file is the file you will create when you convert the file.

 1 Pull down the File menu.  Click on Open.  You will see the Open dialog box.

 2 In the Drives area of the dialog box, click on the
drive that contains your source file.

 3 In the Directories area of the dialog box, click on
the subdirectory that contains your source file.

 4 In the List Files of Type area of the screen, pull
down and select the type of file you wish to open.
If the type of file you have selected has source
image processing options available, the Options
button will become bolded.  

Step 4: Pull Down List Files of Type

Step 1: Open Dialog Box
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 5  [OPT IONAL] If source options are available and you wish to set options,
click on the Options button.  You will see the Source Options dialog box.

Auto Scale options are available to all formats.  These options were
described in Chapter 3: Changing the Look of an Image.

Other source options available to you will depend on the type of file you
are opening.  If you have any questions about specific options on your
screen, click on Help.  You will see a list of options.  Click on a particular
item for more information.

 6 If you set options, click on OK to return to the Open dialog box.  In the File
Name area of the screen, click on the file you wish to open.  Click on OK.
In a few moments the source image will appear on the screen.

Note: HiJaak PRO allows you to open multiple images for conversion.  In
the Open dialog box, hold down the Ctrl key while you click on the files in
the File Name area that you wish to convert.  The images will convert in the
order in which they appear in the list box.

Hint:  If the source image looks bad, your source file may be bad.

If you want, you can edit or process the image before saving it to the same
format or to another format.   To learn more about editing and image processing,
see Chapter 3: Changing the Look of an Image.

 

How to Save the F ile in Another Format

 1 You have opened and are viewing a file.  Pull
down the File menu and click on Save As....  You
will see the Save As dialog box.

 2 Click on the drive and directory where you want
HiJaak PRO to store your converted file. 

Step 1: Save As Dialog Box
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 3 [OPT IONAL]  If you want, you can have HiJaak
PRO pick a destination file type that usually
works well with the software application you are
using (PageMaker, Word for Windows, etc.).  To
allow HiJaak PRO to select for you, click on the
Applications button then click on the application
you will be using.  Click on OK.

 4 If you do not do step 3, you will have to select
your own destination file type.  Click on List
Files of Type and click on the file type to which
you want to convert.

 5 [OPT IONAL]  If you want to set destination file
options, click on the Options button. Destination
processing options are described  later in this
chapter.

 6 [OPT IONAL]  If you want to preview what the converted file will look like,
make sure you have specified everything else in the dialog box, inlcluding
Applications and Options, and then click on Preview.   HiJaak PRO will
take a few moments then show the converted image on the screen.  When
you finish previewing, select Done! from the HiJaak PRO Main menu.  If
you like the results, and would like to save the file, click on OK.  If you
would like to change the results, repeat steps 5 and 6.

 7 If you do not do step 6, click on OK to start the conversion process.

Step 3: Application Dialog Box
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Convert Method

How to Convert a F ile on Disk

 1 Close all open images.  Pull down the File menu.  Click on Convert.  You
will see the Convert From dialog box.

 2 In the Drives area of the dialog box, click on the
drive that contains your source file. 

 3 In the Directories area of the dialog box, click on
the subdirectory that contains your source file.

 4 In the List Files of Type area of the screen, pull
down the list and select the type of file you want
to convert.  If the type of file you have selected
has source image processing options available,
the Options button will become bold and
available. 

 5 [OPT IONAL]  If you want to set options, click on
the Options button. If you want to learn more
about the source options available for your
particular format, click on the Help button.

Important: HiJaak PRO has “ sticky”  editing features.  This means if you
change the color or the font in a file of a particular format and then save it,
when you open other files of that format or convert to that format, those
changes will “ stick”  - or be done automatically.  If you do not want the
changes to affect subsequent editing or conversion sessions, you should use
a special custom-made set file.  For more information on set files, see
Loading and Saving Set Files in Chapter 7: Changing Your Setup.

Step 1: Convert From Dialog Box

Step 2:  Select the Source Drive
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 6 If you set options, click on OK to return to the
Convert From dialog box.  In the File Name area
of the screen, click on the file you want to
convert.  Click on OK.  You will see the Convert
To dialog box.

 7 Click on the drive and directory where you want
HiJaak PRO to store your converted file. 

 8 [OPT IONAL]  If you want, you can have HiJaak
PRO select a destination file type that works well
with the software application you are using (e.g.
PageMaker, Ventura Publisher, etc.).  To allow
HiJaak PRO to select for you, click on the
Applications button and click on the application
you will be using.  Click on OK.

 9 If you do not do step 8, you will have to select your own destination file
type.  Click on List Files of Type and click on the file type to which you
want to convert.

10 [OPT IONAL]  If you want to set destination file options, click on the
Options button. Destination processing options are described later in this
chapter. See the Note on the previous page for information on the
"stickiness" of options.

11 [OPT IONAL]  If you want to preview what the converted file will look like,
make sure you have specified everything else in the dialog box, then click
on Preview.   HiJaak PRO will take a few moments then show the
converted image on the screen.  If you like the results, and would like to
save the file, click on OK.  If you would like to change the image, change
the options by repeating step 10.

12 If you do not do step 11, click on OK to start the conversion process.

T ip: To perform several conversions, press the Ctrl key and click on the
files you want to convert in the File Name area of the Convert From dialog
box.  Click on OK. In the Convert To dialog box, select the File Type to
which you want to convert the files.  You are not allowed to select a File
Name; instead, each file retains its original name.  Each converted file’s
extension will be that of the file type you selected.

Step 6:  Convert To Dialog Box
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How to Convert the F ile You are Currently Viewing

 1 You have opened and are viewing the file you want to convert.  Pull down
the File menu and click on Convert.  You will see the Convert dialog box.

 2 Click on the Convert Current Image to File (Save
As) radio button and click on OK.  You will see
the Save As dialog box.   In the File Name area of
this dialog box, you will see the name of the file
you are viewing.

Note: If you select the Convert File to File radio button and click on OK in
step 2, you will see the Convert From dialog box.  Here, you will be allowed
to select any file on disk to convert.  See  How to Convert a File on Disk
earlier in this chapter for further instructions.

 3 The remainder of this procedure is identical to the Save As method.
Follow steps 2-7 of How to Save the File in Another Format to complete
the conversion.

Step 1: The Convert Dialog Box
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Command L ine Method

How to Convert F iles from the Command L ine

 1 Click on either the Run command in the Windows Program Manager File
menu or the Command selection on the HiJaak PRO File menu. 

 2 If you are using the Program Manager, type
HJPRO [source filename] [destination filename];
if you are using the HiJaak PRO Command
dialog, the leading HJPRO is optional.  All
wildcards that you can use in DOS, you can use in
command line mode. The complete syntax for the
command line is this:

HJPRO  [path/source.ext]
[path/destination.ext]  [-setfile.set]

For example, if the PCX files you want to convert
all begin with IMAGE and are on the D drive, and
you want to convert them to BMP files on the C
drive in the LOOK subdirectory, and you want to
load the Ventura Publisher set file, then type:

HJPRO  d:\image*.pcx  c:\look\*.bmp
-ventura.set 

Note:   For information on what a set file is and how to use one, see
Loading and Saving Set Files in Chapter 7: Changing Your Setup.

Note: Some Windows applications allow you to type a command line
without exiting the application.  If you are interested in running HiJaak
PRO from your application, check your application’s manual. 

Step 1: Command Line Convert
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Destination Processing Options

Processing Options affect the appearance of your destination file.  To select
destination processing options, click on the Options button in the Save As or

the Convert To dialog box.  Some options are available to all formats, some only
to raster formats, and some only to vector formats. Other options may be format
specific.  You learned about raster and vector formats earlier in this chapter.  For
more information on format specific options, click on the Help button in the
Processing Options dialog box.

Processing Options

These processing options are available to all formats.  They are explained in
detail in Chapter 3: Changing the Look of an Image.

q List Color Changes

q Reduce Colors

q Rotate

q Units 

q Maximum Width

q Maximum Height

q Distort Aspect

q Contrast/Brightness

Note:  If you are using the Convert File to File method and you select the
Contrast/Brightness option, you will see an Intensity Curve.  The Intensity
Curve is a graph that displays how the levels of intensity of colors in the
source file will be represented in the image.  The curve will change to show
the results of your Contrast, Brightness and Gamma Correction settings.  If
these three settings are set to zero, the intensity curve will be a straight
diagonal line.  If Contrast is increased, the slope of the instensity curve
increases.   If Brightness is changed the curve shifts up or down, indicating
that the colors become lighter or darker respectively.  If Gamma Correction
is changed, the curve bows up or down, indicating that the medium intensity
colors become lighter or darker respectively.  
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Raster Processing Options

These processing options are only available to raster formats.  They are
explained in detail in Chapter 3: Changing the Look of an Image.

o Scaling

o Horizontal Resolution
o Vertical Resolution
o Smoothing

Vector P rocess ing Options

These processing options are only available to vector formats.

o Curve Quality –– This option
determines how smooth the lines in the
destination file will be.  The three
selections are Fine, Medium, and Coarse.
The finer the line, the longer the
processing time during conversion, and
the larger the resulting file, but the better
the quality.

To select Curve Quality, click on Fine,
Medium, or Coarse in the Curve Quality
pull-down list.

o S troke Fonts –– This option allows
you to have any text in a vector file
drawn or "stroked out" using Windows
text outlines. Use this option if you want
the text in the destination file to appear as
it does on the HiJaak PRO Main screen,
even if your destination file format does
not support the screen font used.

To select Stroke Fonts, click on the
Stroke Fonts check box.

Figure 1: Raster Processing Options

Figure 2: Vector Processing Options
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Capturing a Windows Screen

The following describes how to capture a Windows screen.  If you want to
learn how to capture the screen of an application running under DOS, see

Chapter 6: Capturing a DOS Screen or Printer Output.

Note:  You are using a DOS screen if you do not start Windows or if you
start a DOS shell from the Windows "DOS Prompt" icon.  Be aware that some
programs that can be started from Windows icons are actually using DOS

screens ––  they have a certain DOS "look" about them.  If in doubt, consult
the section in your Windows manual that describes the Windows PIF editor.
If a program is started through a PIF file with the window attribute set to
"full screen," then the program is using a DOS screen. 

Starting Windows Screen Capture 

HiJaak PRO allows you to start a Windows screen capture by using the
hotkeys, the HiJaak PRO icon, or the Capture menu. Which method you

choose depends on the kind of screen captures you will be doing. 

When to Use Hotkey Startup

Use this method if you need to capture a submenu in an application or if you
need  flexibility in capturing your screens.  The hotkey method allows you to
move around freely in Windows and easily choose the full screen, area, or
window you want to capture.  

To use this method, you must remember the hotkey combination.

When to Use Icon Startup

Use this method any time the HiJaak PRO icon is on the screen.

Note that if your application is taking up the full screen, you will not be able to
select this method. When you use this method, your application will not be
active; HiJaak PRO will.  Since your application is not active, you cannot
capture it’s pull down menus. 
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When to Use Capture Menu Startup

Use this method if you need to see the image as it is being captured to the
HiJaak PRO screen.  You can then convert or edit the captured image.  This
method can be used as a learning tool from the Main menu, as it provides
on-line instructions for performing a Windows capture.

Note that when you use this method, your application will not be active; HiJaak
PRO will.  Since your application is not active, you cannot capture its pull down
menus. 

Important Screen Capture Hints

The following hints will help you improve the quality of your screen capture
images and help you work more efficiently.

HINT  1: If you are capturing a screen that you will eventually be printing to a
black and white device (like a laser printer or an imagesetter), select a
monochrome palette for the Windows screen before capturing.  To do this, select
Colors from the Windows Control Panel and specify Monochrome.   Also, if
your black and white printer or imagesetter supports PostScript language, use
HiJaak PRO to convert the captured screen to the PostScript language format
(EPS).  In the Destination Options box, select Snap.  Your PostScript printer will
handle halftoning. 

HINT  2: To get the best quality Windows Screen fonts in your screen captures,
use the highest resolution screen mode for your graphics card and use the
highest resolution screen fonts.  Try to match the resolution of your output
device.

HINT  3: By default, each time you capture a Windows screen, the Windows
Capture Options dialog box will pop up.  If you will be capturing a lot of screens
with the same Windows Capture Option settings, you may want to set HiJaak
PRO so the dialog box does not pop up each time you capture.  To do this, pull
down the Capture menu and click on Windows Capture Options.  Click on the
Prompt for Capture Options check box in the Windows Capture dialog box.
This will de-select the prompt.  If you later want to change options, you will
have to pull down the Capture menu, and select Windows Capture Options.

HINT  4: To capture your application’s pull-down menus, click on the Prompt
for Options check box in the Windows Capture Options dialog box to de-select
it, and use the hotkeys to capture your screen. 
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HINT  5: To include the cursor in your screen shot, click on the Show Cursor
check box in the Windows Capture Options dialog box. Make sure that the
Prompt for Options check box is selected, amd select Screen in the Capture field.

HINT  6: If your application only covers a portion of the screen, and you want to
capture the entire screen, the HiJaak PRO icon or Main screen may be captured
along with your application.  To prevent this, click on the Hide HiJaak  check
box in the Windows Capture Options dialog box.

HINT  7: If you want to place a thin black border around your captured image,
click on the Border check box in the Windows Capture Options dialog box.

HINT  8: If you want the captured image to fit in the HiJaak PRO Main screen,
click on the Scale to Window check box.  This option will change only the
displayed capture, not the actual file.
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How to Capture Screens Using the Hotkeys  

 1 From the HiJaak PRO Main screen, pull down the Capture menu and select
Windows Capture Options.  You will see the Windows Capture Options
dialog box.

 2 In the Capture field, click on the type of object
you want to capture:

o SCREEN –– The entire screen

o WINDOW/OBJECT  –– A specific window,
icon, or pull down menu on the screen

o AREA  –– An area of the screen

 3 If you want the cursor to appear in the image,
click on the Show Cursor check box.

 4 Click on the destination check box in the Capture
To box.  To have the captured image saved as a
file, select File.  To enter a destination filename
in step 6, you must click on File as a destination. 

 5 If you clicked on Capture to File in step 4, click
on the scroll button on the right of the File Type
field.  Scroll to the file format in which you want
to save your captured image.  For example, select
Inset Systems (*.IGF).

 6 If you clicked on Capture to File in step 4, click
on the File Name field.  Type the path and
filename of the file you wish to capture.  If, for
example, you decided to capture the screen into
Inset System’s IGF format, and you would like
the captured file to be on the c: drive, you would
type: 

c:\example.igf

 7 [OPTIONAL] If you selected Capture to File in step 4, you can click on the
Options button to select destination processing options.  See Chapter 3:
Changing the Look of an Image for information on using these options.

Step 1: Windows Capture Options Dialog
Box

Step 5: Selecting the File Type

C
ap

tu
rin

g
 W

in
d

o
w

s

5-4 Capturing a Windows Screen



 8 Note the key combination in the Hotkey field.  These are the keys that you
will use to capture the screen image.  The default keys are Ctrl + Shift + C.
Click on OK to accept the options you have selected.  HiJaak PRO will use
these options each time you capture a  screen until you return to this dialog
box and change the options. 

 9 Click on the down arrow in the upper right hand corner of the screen to
minimize HiJaak PRO.  Move to the screen that contains the image you
want to capture.  

10 Press the hotkey combination you noted in step 8.
The dialog box pops up allowing you to make
any changes to your options before taking the
picture.  If you do not change the filename when
taking several pictures, the program will
automatically increment a numeral in the
filename you specified in the first capture.  For
example, if you entered c:\screens\example1.igf
as the first file, HiJaak PRO will make the next
capture c:\screens\example2.igf.

11 Click on OK. The dialog box will close.  How you capture depends on
whether you selected Screen, Window/Object, or Area in step 2.

CAPTURING A SCREEN:  When you click on OK, you will hear a beep.
This indicates that HiJaak PRO has captured the screen.

CAPTURING A WINDOW/OBJECT: After you click on OK, move the
mouse cursor around the screen.  Notice that as the mouse passes over an
object, the object becomes emphasized. When the window or object you
wish to capture is emphasized, click the left mouse button once. You will
hear a beep signaling that HiJaak PRO has captured the window or object.

CAPTURING AN AREA:  After you click on OK, click and drag the mouse
to define the area you want to capture.  You will see a rectangle.  Release
the mouse button.  You will hear a beep.  This indicates that HiJaak PRO
has captured the area.

Step 11: Capturing an Area
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How to Capture Screens Using the HiJaak PRO Icon 

 1 Run HiJaak PRO.  Click on the down arrow in the upper right hand corner
of the screen to minimize HiJaak PRO.

 2 Run your application and compose the image you
want to capture.  Click on the up and down arrow
in the upper right hand corner of the screen.
Click and pull on the edge of the window to
re-size the image so the HiJaak PRO icon is
visible. 

 3 Click once on the HiJaak PRO icon.  You will see
the HiJaak PRO System menu.

 4 Click on Capture.  You will see a side menu.
Click on the type of object you want to capture:

o SCREEN –– The entire screen

o WINDOW/OBJECT  –– A specific window,
icon, or  pull down menu on the screen

o AREA  –– An area of the screen

You will see the Windows Capture Options
dialog box. Fill in this dialog box as described in
steps 2 through 7 of the How to Capture Screens
Using the Hotkeys procedure earlier in this
chapter. 

 5 Click on OK and capture the image as described
in step 11 of How to Capture Screens Using the
Hotkeys.Step 3: HiJaak Pro System Menu

Step 2: Re-size Image to Make Icon Visible
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How to Capture Screens Using the Capture Pull Down Menu 

 1 Open the application you want to capture.  

 2 If your application is maximized, click once on the up and down arrows in
the upper right hand corner of the screen.  

 3 If the Program Manager is not open already,
double click on the Program Manager icon to
open it, then double click on the HiJaak PRO
program group to open it.  Double click on the
HiJaak PRO icon to open it without closing your
application. Re-size the HiJaak PRO window so
that it is only taking up part of the screen.   You
should now have both your application window
and the HiJaak PRO window on the screen.

 4 In HiJaak PRO, pull down the Capture menu. Click on the type of object
you want to capture:

o AREA  –– An area of the screen

o SCREEN –– The entire screen

o WINDOW/OBJECT  –– A specific window, icon, or  pull
down menu on the screen

HiJaak PRO will become minimized.

 5 You will see a message dialog box stating, "Press the Ctrl-Shift-C hotkeys
to capture the desired Area.  Hint:  You may perform a capture with the
hotkeys at any time when HiJaak is running."  If you have selected hotkeys
other than the default to capture your screens, your selected hotkeys will
appear rather than Ctrl-Shift-C.  If you selected Screen or Window/Object
from the menu, the selected item will appear in the message rather than
Area.  Click on OK.

Step 3: Application and HiJaak Pro       
Sharing the Screen
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 6 Capture the image as described in step 11 of How to Capture Screens
Using Hotkeys. 

 7 If you have not changed the default Prompt for Options setting, you will
see the Windows Capture Options dialog box. Fill in this dialog box as
described in the How to Capture Screens Using the Hotkeys procedure
earlier in this chapter. Click on OK.

 8 Double-click on the HiJaak PRO icon to restore it to its Main screen.
You can now edit the image as described in Chapter 3, or convert the
image as described in Chapter 4. 
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Capturing a DOS Screen or Printer Output

Using HiJaak PRO’s DOS Capture utility, you can either capture screens from
programs running under DOS, or you can print a file from a DOS

application and capture it before it reaches your printer.  Capturing data on the
way to the printer is called “print trap.”  This section first explains how to
capture a screen in a program running under DOS, then it explains how to
capture printer output.

Note: The following describes how to capture a DOS screen.  If you want
to learn how to capture a Windows screen, see Chapter 5: Capturing a
Windows Screen.  If you want to learn how to capture Windows print
output, see your Windows manual for instructions on printing to a file.

Note:  You are using a DOS screen if you do not start Windows or if you
start a DOS shell from the Windows "DOS Prompt" icon.  Be aware that some
programs that can be started from Windows icons are actually using DOS

screens ––  they have a certain DOS "look" about them.   If in doubt, consult
the section in your Windows manual that describes the Windows PIF editor.
If a program is started through a PIF file with the window attribute set to
"full screen," then the program is using a DOS screen. 

How to Capture a Screen in the DOS Environment

 1 From the HiJaak PRO Main screen, pull down the Capture menu and select
DOS Capture Options.  You will see the DOS Capture Options dialog box. 

Step 1: DOS Capture Options Dialog Box
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 2 Pull down the Graphics Card area of the screen.
Click on the type of graphics card in your
computer. 

 3 Note the default in the Hotkey area of the screen.
If you have never changed this option, it will be
Alt + Ctrl.  These are the two keys that, when
pressed at the same time, will initiate HiJaak PRO
Capture later in this procedure.  Do not change
this unless this key combination conflicts with a
memory resident program you have installed.

 4 [OPTIONAL] The following steps are optional
and can be changed at any time.

o If you do not want HiJaak PRO to store
temporary processing files in the default
subdirectory indicated, click on the Temp
Directory area of the screen and enter the path
to the directory you want HiJaak PRO to use
for temporary files. 

o If you have EMS memory in your computer
and you want to reserve some for other
applications, you can type in the maximum
amount (in Kbytes) of EMS memory that you
want to allocate to HiJaak PRO.  If you leave
this space blank, DOS Capture will use as
much EMS as is available.

o If disk space is at a premium, click on
Compressed Files.  The files will be
compressed, but will take longer to process.

o If your DOS text screen captures contain
non-standard fonts, such as those with certain
foreign language text characters, then click on
the Rasterize Text check box. If you rasterize
text, you will not be able to edit fonts using
Change a Font.

Step 2: Specify Graphics Card

Step 3: Specify Hotkey
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 5 In the Capture From area of the screen, click on Screen.  Make sure that
Printer is not checked.  Click on OK.

 6 Double-click on the DOS Capture icon located in the HiJaak PRO program
group.

 7 Run the application which has the screen you want to capture, and bring up
that screen.

 8 Press the hotkeys at the same time. If you did not change the default, these
will be Alt+Ctrl.

 9 You will see a menu prompting you to fill in the
path and filename of the file you will be creating
with this capture.  Type the path and filename
with an IGF file extension.  Press Enter.  HiJaak
PRO stores the captured screen in the file.  If you
leave off the IGF extension, the file extension will
default to the IGF format.  DOS Capture only
supports capturing the image in IGF format.  You
can use HiJaak PRO to convert from IGF to
another format later.

10 Bring up the next screen you want to capture.  You can continue to press
the Alt+Ctrl hotkeys and fill in the filenames until you have captured every
screen you want to capture.  The program will automatically increment a
numeral in the filename you specified in step 9 each time you capture.  For
example, if you entered c:\screens\example1.igf as the first capture file in
step 9, HiJaak PRO will make the next capture c:\screens\example2.igf.

11 When you are finished, exit your application.  At the DOS prompt, type:

EXIT

Note: You can also run the DOS Capture utility by shelling out to DOS, or
exiting Windows and typing doscap at the DOS prompt.  Once you are in
DOS, you can press the hotkeys to capture a screen at any time.  When you
have finished capturing screens, type freecap at the DOS prompt.  If you do
not free DOSCAP, you can continue taking DOS screen shots using the
hotkeys.  However each time you re-boot your computer, you will need to
reload DOSCAP by changing to the HiJaak PRO subdirectory and typing

Step 9: After Pressing the Hotkeys
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doscap.  If you exit Windows instead of using the icon, you must set an
environment variable with a path to your Windows directory.  For example,
SET WINDIR=C:\WINDOWS.

Note: To capture a DOS screen running in an MDI window under Windows
386 enhanced mode, use the Windows Capture option Window/Object.  To
run DOSCAP, the window must be maximized, filling the entire screen.

How to Capture Printer Output

Capturing data on the way to the printer is called "print trap."  HiJaak PRO can
edit or convert the following types of print files:

o HP LaserJet II  (PCL 4 files)

o HP Plotter  (HP 7475A Plotter files)

o Generic ASCII Text  (TXT files)

 1 From the HiJaak PRO Main screen, pull down the Capture menu and select
DOS Capture Options.  You will see the DOS Capture Options dialog box. 

 2 Pull down the Graphics Card area of the screen.  Click on the type of
graphics card in your computer.  

 3 Note the default in the Hotkey area of the screen.  If you have never
changed this option, it will be Alt + Ctrl.  These are the two keys that,
when pressed simultaneously, will initiate DOSCAP later in this procedure.
Do not change it unless this key combination conflicts with a
memory-resident program you have installed. 

 4 [OPTIONAL] The following steps are optional and can be changed at any
time.

o If you do not want HiJaak PRO to store temporary
processing files in the default subdirectory indicated, click
on the Temp Directory area of the screen and enter the
path to the directory you want HiJaak PRO to use for
temporary files.  

o If you have EMS memory in your computer and you want
to reserve some for other applications, you can type in the
maximum amount (in Kbytes) of EMS memory that you
want to allocate to HiJaak PRO.  If you leave this space
blank, Print Trap will use as much EMS as is available.
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o To increase the Printer Time-out, type in the number of
seconds you want HiJaak PRO to wait before assuming an
application has finished printing.  

Note: Information is sent to the printer at irregular intervals; it may take 5
to 20 seconds or more to reach the printer.  If no information has been sent
for 15 seconds, HiJaak PRO assumes that the print job has been completed.
This 15 seconds is the default Printer Time-out value.  If you are only
getting a portion of your print-out, you may need to increase this value. 

 5 In the Capture From area of the screen, click on Printer.  Make sure Screen
is not checked.  Click on OK.

 6 Double-click on the DOS Capture icon located in the HiJaak PRO program
group.  

 7 Set up your application to print the desired file to a parallel printer port (for
example lpt1:), but do not print yet.

 8 Press the hotkeys at the same time. If you did not change the default, these
will be Alt+Ctrl.

 9 You will see a menu prompting you to fill in the
path and filename of the file you will be creating
by doing this capture.  Type a path and filename
if you want to edit the filename.  If the printer
output is HP PCL, HPGL, or TXT, HiJaak PRO can
convert it to other formats. See Chapter 4:
Converting an Image from One Format to
Another.  Select the ouput type appropriate for
your printer.

10 Print as you normally would from your
application to the parallel printer port.  HiJaak
PRO DOS Capture will capture the output on the
way to the printer and route it to the file. 

11 When you are finished, exit your application and from the DOS prompt
type: 

EXIT

Step 9:  Naming the Print Trap File
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Note: You can also run the Print Trap utility by shelling out to DOS or
exiting Windows and typing doscap at the DOS prompt.  Once you are in
DOS, you can press the hotkeys to capture print data at any time.  When you
have finished, type exit at the DOS prompt.  If you do not exit, you can
continue capturing print information using the hotkeys.  However each time
you re-boot your computer, you will need to reload print trap by changing
to the HiJaak PRO subdirectory and typing doscap.  If you exit Windows
instead of using the icon, you must set an environment variable with a path
to your Windows directory.  For example, SET WINDIR=C:\WINDOWS.
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 Changing Your Setup

The HiJaak PRO Main menu has a Setup menu that allows you to customize
HiJaak PRO as follows:

CONFIGURE FAX allows you to select the kind of fax card you have, if any.

CONFIGURE CONVERT allows you to change the buffer size HiJaak PRO will
use during conversions and specify what directory will be used as the temporary
directory during conversions.

FORMAT EXTENSIONS allows you to change which three-letter filename
extension HiJaak PRO associates with a particular format.  It also allows you to
associate a file type in Windows File Manager.

LOAD SETTINGS  and SAVE SETTINGS allow you to save and reload the
configuration files containing the option settings of frequently used file
conversions.

PREFERENCES allows you to select Background Color, Display Palette (Auto
or Fixed), Reduction Method (Snap, Dither, Halftone, or Diffuse), Unit of
Measure (Centimeters or Inches) and Curve Quality.  

Each of these is described in more detail below.

C
h

an
g

in
g

 Y
o

u
r 

S
et

u
p

 

Changing Your Setup 7-1



Configuring HiJaak PRO for Your Fax Card

Fax formats vary substantially.  To deal with this problem, HiJaak PRO allows
you to specify the kind of fax board you have so that when you convert to a

fax format, the converted image will be compatible with your particular fax
card.  A complete list of the fax cards supported by HiJaak PRO is in the format
table at the beginning of Chapter 2. 

Note: If you select a fax device, such as GammaLink, that uses a flavor of
TIF, that flavor will be used whenever you open or convert a file in the TIF
format.

How to Configure HiJaak PRO for Your Fax Card

 1 From the Main screen, pull down the Setup menu and click on Configure
Fax.  You will see the Configure Fax dialog box.

 2 Click on the scroll bar to scroll to the name of the
fax card installed in your computer.

 3 Click on the name of your fax card. 

 4 Click on OK.  You are now ready to convert
images to or from your installed fax card’s
format.  Converting a file is described in
Chapter 4:  Converting an Image from One
Format to Another.

Tip: If your fax device is not on the list, select Generic Fax.

Step 1: Configure Fax
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 Configuring Convert

The Configure Convert option allows you to change HiJaak PRO variables
that affect memory and speed during a file conversion.

BUFFER SIZE:   During a conversion, HiJaak PRO uses a buffer whose size
depends on the kind of conversion being performed.  The default buffer size is
60000; this is the maximum.  If you get an “Insufficient Memory” error, type
10000 in the buffer field.  If you still get the error message, type 8000.  Smaller
numbers allow HiJaak PRO to handle larger conversions, but slow down the
conversion process.  If you are not having problems, leave this field blank.

TEMP DIRECTORY:  During a conversion, HiJaak PRO uses the temporary
directory defined by Windows as an environment variable.  This directory can
only grow as large as the amount of disk space free on the drive that contains
your temporary environment variable.  If you do not want to use the Windows
temporary directory, you can specify another directory in the Configure Convert
dialog box.  If, for example, you type in the path to a RAM disk you have
created, conversions might be quicker.

How to Configure Convert

 1 From the Main screen, pull down the Setup menu and click on Configure
Convert.  You will see the Configure Convert dialog box.

 2 [OPTIONAL] In the Buffer area, type in the size
of the buffer.

 3 [OPTIONAL] Click on the Temp Directory area.
Backspace over the current temp directory path
and type in the path you desire if it is different
from the current path.

 4 Click on OK. 

Step 1: Configure Convert
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Setting Up Format Extensions

Using the Format Extension feature, HiJaak PRO allows you to change which
extensions it associates with a particular format.  This is helpful if all your

files in a particular format have a nonstandard extension.  For example, if all
your TIFF files have the extension OTH, you can use this feature to make HiJaak
PRO recognize OTH extensions as TIFF files.

The Format Extensions feature also allows you to associate a file type with the
file manager.  For example, you can configure HiJaak PRO to immediately open
an OTH file (as a TIFF file) when you double-click on the filename in the File
Manager.

How to Change or Add Format Extension Associations

 1 Pull down the Setup menu and click on Format Extensions.  You will see
the Format Extensions dialog box.

 2 In the Formats list, scroll to the file format you
want to associate with a particular extension.
In the above example, you would highlight TIFF.

 3 Click in the Extension area.  Type the extension
you want to have associated with the highlighted
format.  In the above example, you would type
OTH.  

 4 To add another extension, click on Add.  Repeat
steps 2 and 3 for each association you wish to add.

 5 When you have no more associations to make,
click on OK to accept the associations you have
added.  You will return to the Main menu.

Note: You cannot use a file extension currently in use by HiJaak PRO for
an alias of another format. For example, you cannot use PCX as an alias
for TIF, because PCX is already associated with PC Paintbrush.

Step 1:  Format Extensions Dialog Box
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How to Delete a Format Extension

 1 Pull down the Setup menu and click on Format Extensions.  You will see
the Format Extensions dialog box.

 2 In the Formats list, scroll to the file format you want to delete.

 3 Once your file format name is highlighted, click on Delete.  Click on OK.

How to Register the Extension Associations With the 
Windows File Manager

 1 Pull down the Setup menu and click on Format Extensions.  You will see
the Format Extensions dialog box.

 2 Click on the format type you would like to
register with the File Manager.

 3 Click on Register.  You will see the Register
dialog box.

 4 Click on either the format type you selected in
step 2, or All Formats, to associate with the File
Manager.

 5 Click on OK to return to the Formats Extensions
dialog box.  Click on OK again to accept your
changes and return to the Main menu.

Step 3:  Register Dialog Box
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Loading and Saving Set Files

Every time you convert a file or capture a screen, the options you have set are
saved in a “set file."  Those options become the default option settings for

the next time you start HiJaak PRO and perform the same type of conversion.  If
you do not set new options, HiJaak PRO will use the same option settings as the
last time.  This "sticky" feature of HiJaak PRO allows you to perform complex
operations repeatedly without having to specify options each time.

Settings can get you into trouble if you are not careful.  If, for example, you
have a lot of PCX files that you routinely convert to TIFF to import into Ventura
Publisher, you might want to always substitute a magenta with a particular blue,
and you might want to specify the Ventura Publisher application flavor of TIFF.
This would work fine until you decide to perform the same operation (convert
from PCX to TIFF) to import into PageMaker with no color changes necessary.

To deal with this problem, you could set all the options for your Ventura
Publisher conversion, perform the conversion, then save the settings as
“ventura.set."  This is described in How to Save Settings, below.  You would
then do the same for your PageMaker conversion, but save the settings as
“pagemak.set."  Then, before doing a PageMaker conversion, you would go into
Load Settings and select pagemak.set.  Loading settings is described in How to
Load Settings later in this chapter. 

If you have made a lot of option changes, you may wish to restore the original
defaults that were shipped with HiJaak PRO.  This is described in How to
Re-load the Original Settings later in this chapter.
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How to Save Settings

 1 Complete the operation with the settings you would like to save as the
default.  For example, set all the options and then either convert the file or
capture the screen.

 2 From the Main menu, pull down the Setup menu
and click on Save Settings.  You will see the Save
Settings dialog box.

 3 HiJaak PRO will look for the set file in the
directory where your Windows win.ini file is.
Unless you are on a network and are sharing set
files, you will probably want to leave the
Directories, Drives, and List Files of Type areas
of the window unchanged. 

 4 Click on the File Name area of the window.  Type in the name under which
you want to save your set file. 

 5 Click on OK.

How to Load Settings

 1 When you need the saved settings, pull down the Setup menu and click on
Load Settings.  You will see the Load Settings dialog box.

 2 Select the drive and directory where you saved
the set file.

 3 In the File Name area of the screen, click on the
name of the set file you want to load.  

 4 Click on OK to load the set file.

Step 2: Save Settings Dialog Box

Step 1: Load Settings Dialog Box
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How to Re-load the Original Settings

 1 Before performing an operation to which you want to apply the original
default settings, pull down the Setup menu and click on Load Settings.
You will see the Load Settings dialog box.

 2 Click on the Defaults button to load the original settings.

Preferences

HiJaak PRO allows you to control your image’s background color, the screen
display palette, the color reduction method, the unit of measure, and the

curve quality you want to use in HiJaak PRO.  

BACKGROUND  COLOR: The Background Color feature lets you change the
background color in vector images and the padding color in raster images.  

PALETTE DISPLAYED: The Palette Displayed controls will only work on a 256
color monitor.  The selections (Auto and Fixed) change the behavior of the
“palette,” or set of colors on your monitor.  

REDUCTION  METHOD: The Reduction Method options allow you to control
color processing for viewing.  

UNITS: The Units option allows you to specify either centimeters or inches.
HiJaak PRO will use this as the unit of measure throughout the program. 

CURVE QUALITY: The Curve Quality selection determines the smoothness of
the lines HiJaak PRO will create in a destination file.  Curve Quality is only
valid when converting files that contain a special kind of complex curve called a
Bezier curve.  If your image does not contain Bezier curves, this option will
have no effect on the image. The three quality selections are Fine, Medium and
Coarse.  The finer the line, the longer the processing time during conversion and
the larger the resulting file, but the better the image quality will be.

STATUS BAR: The Status Bar option allows you  to choose what information
you want displayed in the bar at the bottom of the HiJaak PRO Main screen.
You have two choices: Show Cancel Button and Show Percent Done. The
Cancel Button lets you stop any processing option by clicking on it. The Show
Percent Done option lets you see the progress of any processing option. The
default for both options is on.
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How to Change Background Color

 1 To change the Background Color, from the Main menu, pull down the Setup
menu and click on Preference.  You will see the Preferences dialog box. 

 2 Click on the down arrow next to Background
Color to pull down the Background Color list.  

 3 Click on the color you want as the background.

How to Change the Palette Displayed

 1 To change the Palette Displayed, from the Main menu, pull down the Setup
menu and click on Preference.  You will see the Preferences dialog box. 

 2 Click on the down arrow next to Palette
Displayed to pull down the Palette Displayed list.

 3 Click on the selection you want.  Each is
described below.

Step 2:  Background Color List

Step 2:  Palette Displayed List
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AUTO:   This is the default display palette. If you have one image open and you
choose Auto, the palette of the image becomes variable.  That is, the palette of
the active image becomes the dominant palette.  Background images will be
re-painted with the dominant palette. If you have more than one image open and
you select Auto, the palette becomes fixed.

FIXED:  When you choose Fixed, all images on the screen will share the same
palette.  This setting will not produce the optimal result for any particular image,
but it will eliminate background image processing and is therefore faster. 

Note: If you want to change colors on other standard Windows areas such
as the title bar, application workspace, etc., click on the Colors selection in
the Windows Control Panel.

 

How to Change the Color Reduction Method

 1 To change the color reduction method, from the Main menu, pull down the
Setup menu and click on Preferences.  You will see the Preferences dialog
box. 

 2 Click on the down arrow next to Reduction
Method to pull down the Reduction Method list. 

 3 Click on the color reduction method you want
HiJaak PRO to use when viewing an image. Each
option was described in the Reduce Colors
section of Chapter 3: Changing the Look of an
Image.

Step 2:  Reduction Method List
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How to Change the Default Unit of Measure

 1 To change the default unit of measure, from the Main menu, pull down the
Setup menu and click on Preferences.  You will see the Preferences dialog
box. 

 2 Click the down arrow next to Units to pull down
the Units of Measure list. 

 3 Click on the Unit of Measure you want HiJaak
PRO to use as the default throughout the program.

How to Change Curve Quality

 1 To change the Curve Quality, from the Main menu, pull down the Setup
menu and click on Preferences.  You will see the Preferences dialog box.

 2 Click on the down arrow next to Curve Quality to
pull down the Curve Quality list.

 3 Click on the Curve Quality you want HiJaak PRO
to use.  You have the choice of Fine, Medium and
Coarse.

Step 2:  Curve Quality List

Step 2:  Units of Measure
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Us ing HiJaak PRO in Your Work

You can use HiJaak PRO with most software applications and graphics
hardware.  Using the HiJaak PRO Object Linking and Embedding (OLE)

feature, you can link or embed objects into any client application.  Using the
HiJaak Retrieve Macro, you can import supported files into WordPerfect for
Windows.  Using HiJaak PRO import filters, you can import files in any HiJaak
PRO supported format into any application that supports the Aldus graphic
import filter specification.

HiJaak PRO also supports TWAIN.  TWAIN is a protocol developed by leading
graphics hardware and software developers, which allows you to bring images
into HiJaak PRO from your graphics hardware.  Using OLE or HiJaak PRO
graphic import filters, you can  import these images into your documents,
presentations, spreadsheets, etc. The following types of hardware may be
compatible with TWAIN:

q Desktop Scanners

q Hand-held Scanners

q Slide Scanners

q Frame Grabbers

q Digital Cameras
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Us ing HiJaak Import F ilters

HiJaak import filters follow the Aldus graphics import filter specification.
The HiJaak import filter allows applications that support the Aldus

specification to import graphics in any of the more than 70 formats that HiJaak
PRO supports.  The following sections describe how to use HiJaak import filters
to import files into the following applications:

q PageMaker

q Persuasion

q FreeHand

q Ami Pro

q Word for Windows

q PowerPoint

Note: If you install any of these applications after you install HiJaak PRO,
you can still use HiJaak import filters.  Double-click on the HJSetup icon
located in your HiJaak PRO program group.  Select Import Filter Install
and follow the instructions on your screen to add HiJaak import filter
support to your new applications.
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How to Import an Image into PageMaker

 1 Start up PageMaker and open the document into which you want to import
an image. 

 2 From the File menu, select Place.  You will see
the Place dialog box.

 3 From the Files/Directories list box, select the path
and filename of the image that you want to
import.

 4 [OPT IONAL]  If you want to set processing
options, press and hold the Shift key as you click
on OK. You will see the HiJaak PRO Processing
Options dialog box.  Select your options.  For
more information on Options, see Chapter 3:
Changing the Look of an Image.

 5 Click on OK. You will see the HiJaak Import
status box, showing percent completion of the
import.  When the file has successfully imported,
the status box disappears and you will see the
PageMaker Place cursor.  Click in the document
where you want the upper-left corner of the
image to appear.

Step 2:  Pagemaker Place Dialog Box

Step 4:  HiJaak Import Options Dialog Box
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How to Import an Image into Persuasion

 1 Start up Persuasion and open the document into which you want to import
an image.

 2 Pull down the View menu and select Slide.

 3 Pull down the File menu and select Place.  
You will see the Place dialog box. 

 4 From the Directories list box, select the drive and
directory of the file you want to place.

 5 In the Files list box, click on the filename of the
image you want to import.

 6 [OPT IONAL]  If you want to set processing
options, press and hold the Shift key as you click
on OK. You will see the HiJaak PRO Processing
Options dialog box.  Select your options.  For
more information on Options, see Chapter 3:
Changing the Look of an Image.

 7 Click on OK. You will see the HiJaak Import status box, showing percent
completion of the import.  When the file has successfully imported, the
status box disappears and you will see the Persuasion Place cursor.  Click
in the document where you want the upper-left corner of the image to
appear.

How to Import an Image into F reeHand

 1 Start up FreeHand and open the document into which you want to import
an image.

 2 Pull down the File menu and select Place.  You will see the Place dialog
box. 

 3 In the Directories list box, select the drive and directory of the file you
want to place.

 4 In the Files list box, click on the filename of the image you want to import.

Step 3:  Persuasion Place Dialog Box
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 5 [OPT IONAL]  If you want to set processing options, press and hold the
Shift key as you click on OK. You will see the HiJaak PRO Processing
Options dialog box.  Select your options.  For more information on
Options, see Chapter 3: Changing the Look of an Image.

 6 Click on OK. You will see the HiJaak Import status box, showing percent
completion of the import.  When the file has successfully imported, the
status box disappears and you will see the FreeHand Place cursor.  Click in
the document where you want the upper-left corner of the image to appear

How to Import a Picture into Ami Pro

 1 Start up Ami Pro and open the document into which you want to import a
picture.

 2 Place the cursor at the point you would like the
upper-left corner of the image to appear.

 3 Pull down the File menu and click on Import
Picture.  You will see the Import Picture dialog
box.

 4 From the File type field, select the file format
type you want to import.  If, for example, you
wanted to import a file in the Amiga IFF format,
you would click on HiJaak Amiga.

 5 From the Drives pull down, select the drive of the
file you want to import.  From the Directories list
box, select the directory, and from the Files list
box select the image you want to import.  Click
on OK.

 6 You will see the HiJaak PRO Processing Options dialog box.  Select your
options.  For more information on Options, see Chapter 3: Changing the
Look of an Image.

 7 Click on OK. You will see the HiJaak Import status box, showing percent
completion of the import.  When the file has successfully imported, the
status box disappears and the image appears in the Ami Pro document at
the point you selected.

Step 3:  Ami Pro Import Picture Dialog Box
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How to Import a Picture into Word for Windows

 1 Start up Word for Windows and open the document into which you want to
import a picture.

 2 Place the cursor at the point you would like the
upper-left corner of the image to appear.

 3 Pull down the Insert menu and select Picture.
You will see the Picture dialog box.

 4 From the Drives pull down, select the drive of the
file you want to import.  From the Directories list
box, select the directory of the file you want to
import. 

 5 In the File Name area, select the filename of the
picture you want to import.

 6 Click on OK.  You will see the HiJaak PRO Processing Options dialog
box.  Select your options.  For more information on Options, see Chapter
3: Changing the Look of an Image.

 7 Click on OK. You will see the HiJaak Import status box, showing percent
completion of the import.  When the file has successfully imported, the
status box disappears, and the image appears in the Word document at the
point you selected.

Note: Word for Windows supports a 16 color display and a 256 color
print-out.  If you are importing a 256 color graphic into Word, it might not
display as you expect; it will, however, print as you expect.  If the display of
your 256 color image is more important to you than the appearance of the
printed image, then use HiJaak PRO to reduce the number of colors to 16.
From the HiJaak PRO Colors menu, select Reduce Colors.  In the Number
of Colors field, select 16.  Click on the Optimize Palette check box.  HiJaak
PRO will match the closest 16 colors to those in your 256 color image.

.

Step 3: Word Picture Dialog Box
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How to Import a Picture into PowerPoint

 1 Start up PowerPoint and open the document into which you want to import
a picture.

 2 Pull down the Edit menu and select Insert.  You
will see the Insert side menu.

 3 Select Picture.  You will see the Insert Picture
dialog box.

 4 From the Drives pull down, select the drive of the
file you want to import.  From the Directories list
box, select the directory of the file you want to
import. 

 5 In the File Name area, select the filename of the
picture you want to import.

 6 Click on OK. You will see the HiJaak PRO Processing Options dialog box.
Select your options.  For more information on Options, see Chapter 3:
Changing the Look of an Image.

 7 Click on OK. You will see the HiJaak Import status box, showing percent
completion of the import.  When the file has successfully imported, the
status box disappears and the image appears in the PowerPoint presentation
at the point you selected.

Step 3:  PowerPoint Insert Picture Dialog
Box
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Us ing HiJaak PRO with WordPerfect for Windows

HiJaak PRO is linked to WordPerfect for Windows through WordPerfect’s
Macro facility via a DDE link.  (DDE is an acronym for Dynamic Data

Exchange.)  This link is set up by HiJaak PRO when you perform either a Full
install, or a Custom install with Application Interfaces.  This install adds the
"HiJaak Retrieve" item to WordPerfect’s Macro menu.  This link is useful
because, once selected, the HiJaak Retrieve item instantly starts up HiJaak PRO
and allows you to place a file into WordPerfect in any one of more than 70
formats supported by HiJaak PRO.  The HiJaak Retrieve Macro automatically
converts the files to formats WordPerfect can read.

Note: WordPerfect 5.2 also allows you to import using Object Linking and
Embedding (OLE).  See the section on OLE later in this chapter.

How to R etr ieve a Graphics F ile Us ing the HiJaak R etrieve Macro

Warning: When you use the HiJaak Retrieve Macro, any information that
you have previously copied to the clipboard will be deleted.

 1 Start up WordPerfect for Windows and open the file into which you want
to place a graphic.  If you are creating a new document, you must save it
before trying to import a HiJaak object through the macro link.

 2 Place your cursor at your desired insertion point.

 3 Pull down the Macro menu.  Select HiJaak
Retrieve. HiJaak PRO starts up, and the HiJaak
Retrieve dialog box appears on the screen.  
A WordPerfect Macro Facility icon and a HiJaak
PRO icon appear at the bottom of the screen (you
may have to reduce the size of your WordPerfect
window in order to see these icons).

 4 Select the graphics file you want to import.  Click
on OK.

 5 Using your current set file options, HiJaak PRO converts this image and
places it into your WordPerfect document at your specified insertion point.

 6 When you have no more files to retrieve, click on the HiJaak PRO icon and
select Close.

Step 3:  The HiJaak Retrieve Dialog Box
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Note: HiJaak PRO remains active so you may retrieve additional files
through the Macro menu.

How to Manually Ins tall the Macro L ink 

If you want to manually set up the DDE link between HiJaak PRO and
WordPerfect for Windows, or if you install WordPerfect for Windows after
HiJaak PRO, follow this procedure to install the macro link:
 1 From the WordPerfect Main menu, pull down the Macro menu and select

Assign to Macro. You will see the Assign Macro to Menu dialog box.

 2 Click on Insert.  You will see the Insert Macro
Menu Item pop up box.

 3 In the Macro Name field, type your path to
HiJaak PRO followed by the filename
HJIMPORT.WCM. (This must be in a writable
directory).  If, for example, you installed in the
default directory, you would type: 

   c:\hjpro\hjimport.wcm

 4 In the Menu Text field, type:

   HiJaak Retrieve

 5 Click on OK to exit each of the dialog boxes.  HiJaak Retrieve is added to
your Macro menu.

HiJaak PRO must be in your search path in order for the HiJaak Retrieve Macro
to work properly.  If it is not in your search path, you will get theWordPerfect
error message: "Error Loading HiJaak - Error2!"  To put HiJaak PRO in your
search path, first open your AUTOEXEC.BAT file in an ASCII editor.  Find the
statement in your AUTOEXEC.BAT file that begins with PATH= and move to the
end of that line.  Add your HiJaak PRO directory to the list. (Subdirectories must
be separated by semicolons.)  See the following example:

Exis ting Path: Path = C:\;C:\WIN;C:\BAT
Modified Path: Path = C:\;C:\WIN;C:\BAT;C:\HJPRO

After you save your file in ASCII format, you must re-boot your machine in
order for the new Path statement to take effect.

Step 2:  Insert Macro Menu Item Dialog Box
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How to Cancel the HiJaak Retrieve Import

If you are encountering problems with the HiJaak Retrive import, you may want
to cancel it.  Follow the procedure below.
 1 Double-click on the WordPerfect Macro Facility icon.  You may have to

minimize WordPerfect in order to see this icon.  The Macro Facility screen
appears.

 2 From the Macro menu, select Terminate Macro.
You will receive the message, "The execution is
being terminated at the request of the Macro
Facility." Click on OK.

 3 Pull down the File menu and select Exit.

 4 Click on the HiJaak PRO icon and select Close.

 5 From the WordPerfect Main menu, select Edit.  

 6 Select Links.  You will see the Links dialog box.
In the Link Types field, click on Show DDE
Links.

 7 Click on HiJaak Request Import Automatic.
Click on the Cancel Link button. Click on OK.
The link between HiJaak PRO and WordPerfect
for Windows is canceled. 

Step 6:  The Links Dialog Box

Step 2:  Terminating the Macro
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Us ing HiJaak PRO with F ile Manager

HiJaak PRO integrates with Windows 3.1 File Manager to select files for
viewing and printing using "double-clicking" and "Drag-Drop." With this

capability, you can use HiJaak PRO as a quick file viewer for all HiJaak
PRO-supported source formats.  Once you are viewing the image, you can edit,
process, or convert it.

Before you can use these capabilities, you must make associations between
HiJaak PRO and the desired formats.  You do this by registering HiJaak PRO
with its compatible file formats. See Chapter 7: Changing Your Setup for more
information.

Us ing HiJaak PRO as  a F ile Viewer

There are two ways to view files from File Manager.  One uses double-clicking,
the other uses Drag-Drop.

How to View an Image Using Double Clicking

 1 Open File Manager.

 2 Select the appropriate directory and double-click on the name of the image
file you would like to view.  HiJaak PRO automatically starts up and views
the file.

 3 When finished viewing, pull down the File menu and select Exit.
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How to View an Image Using Drag-Drop

 1 Open HiJaak PRO by double-clicking on its icon.

 2 Click on the down arrow in the upper-right corner of the HiJaak PRO Main
screen to minimize it into a running icon.

 3 Open File Manager.

 4 Select the appropriate directory and click and hold the mouse button down
on the name of the image file you would like to view.  The file name will
become highlighted and the file will turn into an icon when you drag.

 5 Drag the file icon to the HiJaak PRO icon and drop it there by releasing the
mouse button.

 6 Click on the HiJaak PRO icon and select Restore.  The HiJaak PRO Main
screen will open, allowing you to view the file you selected.

You may also use HiJaak PRO Drag-Drop capabilities when its Main
screen is open by dropping the file icon directly on the open window.

You may even use this Drag-Drop capability if the HiJaak PRO icon is
inactive.  If you do this, the Program Manager will create another HiJaak
PRO icon and give it the same name as your selected file.  You view the
file by double-clicking on the new icon.  This second icon is useful if the
contents of the file change frequently.  After closing the file and exiting
HiJaak PRO, you can delete the icon by clicking on it once and pressing the
Delete key.
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How to View Multiple Images Using Drag-Drop

 1 Open HiJaak PRO by double-clicking on its icon.

 2 Click on the down arrow in the upper-right corner of the HiJaak PRO Main
screen to minimize it into a running icon.

 3 Open File Manager.

 4 Press the left mouse button and hold down the Ctrl key while you click on
each file you wish to view. 

 5 After you have selected your last file, release the Ctrl key, but continue to
hold down the mouse button.  Your selected files will turn into an icon
when you drag.

 6 Drag it to the the HiJaak PRO icon and drop it there by releasing the mouse
button.

 7 Double-click on the HiJaak PRO icon.  The HiJaak PRO Main screen will
open, allowing you to view the all the files you selected.
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Printing F iles  from F ile Manager

HiJaak PRO allows you to print files to the default printer directly from File
Manager using Drag-Drop.

How to Print from the F ile Manager

 1 To open File Manager, double-click on its icon  

 2 Double click on the Print Manager icon.  Click on the down arrow in the
upper-right corner of the window to minimize it into a running icon.

 3 Select the file you would like to print by clicking on it once and holding
the mouse button down.  The file will turn into an icon when you drag.

 4 Drag the file icon to the Print Manager icon and drop it by releasing the
mouse button.

 5 You will see the HiJaak PRO Print dialog box.  Specify your printing
options and click on OK.  The selected file is automatically sent out to the
printer.

Note: Windows allows you to drop only one file at a time on the Print
Manager.U
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Adding Icons  to the Program Manager

HiJaak PRO allows you to convert any supported file into an icon for use in
the Windows Program Manager.

How to Add an Icon to the Program Manager

 1 Use HiJaak PRO to convert your graphics file to the ICO file format.
Conversions are explained in Chapter 4: Converting a File form One
Format to Another.

 2 In Windows Program Manager, click once on the
icon you want to replace.

 3 Pull down the Program Manager File menu and
click on Properties.  You will see the Program
Item Properties dialog box.  

 4 Click on the Change Icon button.  You will see
the Change Icon dialog box.

 5 Click on the Browse button.  You will see the
Browse dialog box.

 6 Select the drive and directory where you saved
your icon (*.ICO) file.  Click on the name of the
file you want to use as your icon.

 7  To change the selected icon, click on OK in each
dialog box.

Step 3:  The Program Item Properties
Dialog Box

Step 4:  The Change Icon Dialog Box
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L inking and Embedding HiJaak Objects in Your Applications

HiJaak PRO is an Object Linking and Embedding (OLE) Server.  This feature
allows you to place HiJaak objects, which are graphic images, into any

client application.  Client applications are usually desktop publishers and word
processors.  HiJaak PRO cooperates with OLE Clients to allow you to create
documents containing a variety of images.  These are called compound
documents.  Although the Windows cut and paste function is similar, OLE
allows you to edit after you have inserted the object.  You can easily manipulate
images without ever leaving the document.  

When to E mbed an Image 

You should embed an image if you need one complete document.  For example,
if you plan to work on your document at different workstations, you need all that
document’s information saved in one file.  Embedding allows this.

When to L ink an Image

You should link an image when you want smaller file size.  When you link, only
the link joining the application, the object, and HiJaak PRO is saved with the
client application, not the entire image file.  This keeps file size small.  Linking
is particularly useful because it allows you to maintain graphics files separately
from your document files. Use HiJaak PRO to edit the files and they update
dynamically in your application.
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Note: Many applications, such as Microsoft Word, Ami Pro, Ventura 4.0,
WordPerfect 5.2, Write, and Excel,  act as OLE clients. Since Write is
available to all Windows users, it will be used as an example in the
following procedures.  The procedures for Windows Write are very similar
to the procedures for other applications.

How to L ink a HiJaak Image to a Write Document

 1 Start HiJaak PRO.

 2 Open the file that you want to link to your Write document.

 3 Pull down the Edit menu and select Copy As.
You will see the Select Clipboard Format dialog
box.  For raster images, select Windows 2
Bitmap.  For vector images select Windows
WMF.  After selecting  the appropriate format for
your image, click on OK.  

 4 Double-click on the Windows Write icon to open
the application.  Write is usually located in the
Accessories Program Group.

 5 Pull down the Edit menu and select Paste Special.
You will see the Paste Special dialog box.

 6  From the Data Type list box, select HiJaak
Image.

 7 Click on Paste Link.

 8 Your selected HiJaak image will appear in your
document.

Step 3: Select Clipboard Format

Step 5: Paste Special Dialog Box
U

si
ng

 H
iJ

aa
k 

P
R

O

Us ing HiJaak PRO 8-17



Note: In step 7 of the above procedure, if you select Paste rather than
Paste Link, you will embed the object in your document, rather than link it
to your document.

Note on MS  Word: When using OLE with HiJaak PRO and Word for
Windows, Word will give you the choice in the Data Type list box between
"HiJaak Image Object" and "Picture."  To link the image, you must select
Picture.  To embed the image, you must select HiJaak Image Object.

How to Edit a L inked HiJaak Image from the Write Document 

 1 Double-click on the linked object.

 2 HiJaak PRO starts up with the object appearing in the Main screen.
Perform any of the editing functions available in HiJaak PRO.

 3 Pull down the File menu and select Save.

 4 Select Exit from the File menu.  The linked object will be updated with
your newest editing changes.

How to Edit a L inked HiJaak Image from HiJaak PRO

 1 Start up HiJaak PRO and open the graphics file containing the linked
object; perform any of the editing functions available in HiJaak PRO.

 2 Pull down the File menu and select Save. 

 3 Pull down the File menu and select Exit.

 4 Open Windows Write.

 5 Open the document containing your linked object.  You will receive a
message asking if you want to update your document file with the edited
version of the object.  Select OK.  File Manager updates the Write
document with the edited object.
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How to Embed a HiJaak Image into a Write Document

 1 Double-click on the Windows Write icon to open the application.

 2 Open the document into which you want to
embed a HiJaak object. Scroll down in your
document to the desired point of insertion, and
place your cursor there.

 3 Pull down the Edit menu by clicking on it once.
Select Insert Object.  You will see the Insert
Object dialog box.

 4 From the Object Type list box, select HiJaak
Image and click on OK.

 5 HiJaak PRO starts up and the Open dialog box
appears.  Select the image you want to embed
into your Write document.

 6 The HiJaak PRO Main screen appears with your
selected file displayed.  Pull down the HiJaak
PRO File menu and select Update Write.

 7 Processing occurs as the graphics file is
embedded into your document.  Pull down the
File menu and select Exit and Return to Write.

 8 HiJaak PRO closes, and the image appears in your
document.

Step 3: Insert Object Dialog Box

Step 6&7: HiJaak Pro OLE File menu
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How to Edit an E mbedded HiJaak Image in a Write Document

  1 Double-click on the embedded object.  A frame with handles appears
around the object, and HiJaak PRO starts up with the object appearing in
the Main screen.

 2 Perform any of the editing functions offered by HiJaak PRO.

 3 Pull down the File menu and select Update Write.

 4 Pull down the File menu and select Exit and Return to Write.

The editing changes you made to the object in HiJaak PRO will be updated
in Windows Write due to the link between the two applications via this
object. 

Note:  In a 256 color display, many applications may not automatically
repaint an OLE HiJaak Object after the display palette changes, or may
only display one palette at a time.  If each image in an open document has a
special palette, they may not all display correctly.  This is not a cause for
concern.  Regardless of the display, HiJaak PRO remembers the correct
palette information.

If You Have Problems With Embedding: The following problems may occur
during embedding.

q HiJaak PRO beeps when starting up and opens to the Main
menu rather than the Open dialog box.

q The File menu does not have an Update Write entry.

q Write gives the message "Unable to communicate with
source application," when HiJaak PRO exits.

If these problems occur, then the Registration Database probably has an
incorrect or corrupt entry for "HiJaak Image."  You can fix this problem by using
the RegEdit application provided with Windows.
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How to Add the Regedit Icon

 1 In the Program Manager, click on the Accessories Group Window.

 2 From the File menu, select New.

 3 Click on Program Item and then on OK.

 4 In the Description Field, type

 regedit  

 5 In the Command Line Field, type in your path to Windows 3.1 followed by
REGEDIT.EXE.  Click on OK.  The Regedit icon will be added to your
Accessories Group.

How to F ix Your R egistration Database Problems

 1 Double-click on the Regedit icon to open the Registration Info Editor.

 2 Click on HiJaak image.

 3 Click on Edit and select Delete File Type.  You
will receive the message, "Are you sure you want
to delete ‘HiJaak Image’  File Type?"  Click on
Yes.  "HiJaak Image" will disappear from the list. 

 4 Repeat steps 2 and 3 if more than one "HiJaak
Image" entry exists.

 5 Click on File and select Exit.

 6 Start and exit HiJaak PRO to re-register it for
"HiJaak Image."

Note: Registering for "HiJaak Image" is different from registering for file
type, in that registering for "HiJaak Image" happens automatically
whenever HiJaak PRO starts up.

Step 3:  Deleting HiJaak Image Entry

U
si

ng
 H

iJ
aa

k 
P

R
O

Us ing HiJaak PRO 8-21



Us ing T WAIN to Import Images from Your Graphics  Hardware

To import an image from your graphics hardware using the TWAIN interface,
follow the instructions below. 

How to Select Your Hardware

 1 Pull down the File menu and click on Select Source.  You will see a list of
all available TWAIN devices.

 2 Click on the graphics hardware device from which you want to import an
image.  Click on OK.

How to Import an Image Using T WAIN

 1 Pull down the File menu and select Acquire.  You will see an Acquire
dialog box.

 2 Acquire dialog boxes vary from device to device.  See your graphics
hardware documentation for more information.  

 3 Fill in the dialog box and click on OK.  The image will import into HiJaak
PRO.
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Technical S upport

Support for this version of HiJaak Pro is provided by your system vendor.

Before contacting the system vendor for support, please check to make sure that
you have the following:

q Windows 3.1 or later in standard or enhanced mode

q Sufficient disk space

q Available system resources above 25%

q A supported graphics card, if you are using DOSCAP

q A supported fax card, if fax transmission is desired

When you call for technical support, if at all possible, be at your computer with
your HiJaak PRO User Guide handy.  In order to obtain quick and efficient help,
please have the following information:

q Serial Numbers

q Any TSR’s that are loaded, including network drivers

q Detailed description of the problem, including exact
wording of any error messages
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